summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-08-20 11:39:24 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-15 11:09:23 +0300
commit4f5835f7865fa9fb1a53878772b4f0fe2324008b (patch)
tree727850371e740ece79ebaa690616e87f825124a1 /dev-python/spyder-unittest
parentdev-python/spyder-memory-profiler: does not work with spyder-5 (diff)
downloadgentoo-4f5835f7865fa9fb1a53878772b4f0fe2324008b.tar.gz
gentoo-4f5835f7865fa9fb1a53878772b4f0fe2324008b.tar.bz2
gentoo-4f5835f7865fa9fb1a53878772b4f0fe2324008b.zip
dev-python/spyder-unittest: does not work with spyder-5
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/spyder-unittest')
-rw-r--r--dev-python/spyder-unittest/spyder-unittest-0.4.1.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/spyder-unittest/spyder-unittest-0.4.1.ebuild b/dev-python/spyder-unittest/spyder-unittest-0.4.1.ebuild
index 5a999c55cae6..14eb1d313ebb 100644
--- a/dev-python/spyder-unittest/spyder-unittest-0.4.1.ebuild
+++ b/dev-python/spyder-unittest/spyder-unittest-0.4.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_7 )
+PYTHON_COMPAT=( python3_{7,8} )
inherit distutils-r1 virtualx
@@ -15,14 +15,19 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND=">=dev-python/spyder-4.0.0[${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-python/spyder-4.0.0[${PYTHON_USEDEP}]
+ <dev-python/spyder-5.0.0[${PYTHON_USEDEP}]
dev-python/pyzmq[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]"
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
DEPEND="test? (
dev-python/flaky[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pytest-qt[${PYTHON_USEDEP}] )"
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
distutils_enable_tests pytest