summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-04 14:53:11 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-04 14:53:14 +0200
commit606ad76a56b847a50811a62ee113bbd6f65f6a45 (patch)
treeef498c2c05404d488b882a1738290ae92dd9a1ad /dev-python/sphinxcontrib-apidoc
parentdev-python/django: Bump to 3.2.21 (diff)
downloadgentoo-606ad76a56b847a50811a62ee113bbd6f65f6a45.tar.gz
gentoo-606ad76a56b847a50811a62ee113bbd6f65f6a45.tar.bz2
gentoo-606ad76a56b847a50811a62ee113bbd6f65f6a45.zip
dev-python/sphinxcontrib-apidoc: Bump to 0.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-apidoc')
-rw-r--r--dev-python/sphinxcontrib-apidoc/Manifest1
-rw-r--r--dev-python/sphinxcontrib-apidoc/sphinxcontrib-apidoc-0.4.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-apidoc/Manifest b/dev-python/sphinxcontrib-apidoc/Manifest
index c72ab4440d6e..2fca730c5316 100644
--- a/dev-python/sphinxcontrib-apidoc/Manifest
+++ b/dev-python/sphinxcontrib-apidoc/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-apidoc-0.3.0.tar.gz 15396 BLAKE2B de726316daa81eae1a8012c8be4acf3850f910af562d23dc17194afc86b40daf632bd5cdd61153299f35f3326b181c3b67e75925f0d95ce4cea81e1766c7828d SHA512 043f9b36eaff7b3f6d23c834dd3947e2b029c66010b3862f1658f03e0fb6c4aac3304f49465dd515a30107a685dc704a0e319675c9d7b27897445a2c315d07a1
+DIST sphinxcontrib-apidoc-0.4.0.tar.gz 15958 BLAKE2B 9cd806eb36cd2aa35c797b35e8e699c4a918e8e3d19e36ea9d79eb73dfce301a24ee33bc647ba180283837488aa00628b4882d08c3d492b196a4f663cad26f48 SHA512 1e33fd6df91adfb65ea511fe5ee55ccff9a237488cca406f46b33a2bf8eb69b884b274e9c94bfd868fef67b2e0dfbb19f5e2d62486c54a85755a9034ca5c715c
diff --git a/dev-python/sphinxcontrib-apidoc/sphinxcontrib-apidoc-0.4.0.ebuild b/dev-python/sphinxcontrib-apidoc/sphinxcontrib-apidoc-0.4.0.ebuild
new file mode 100644
index 000000000000..78b537d913ed
--- /dev/null
+++ b/dev-python/sphinxcontrib-apidoc/sphinxcontrib-apidoc-0.4.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension for running sphinx-apidoc on each build"
+HOMEPAGE="
+ https://pypi.org/project/sphinxcontrib-apidoc/
+ https://github.com/sphinx-contrib/apidoc/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${BDEPEND}
+ >=dev-python/sphinx-5.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ cd "${T}" || die
+ epytest "${S}"/tests
+}