summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-07-24 09:54:05 +0200
committerDavid Seifert <soap@gentoo.org>2017-07-30 11:34:09 +0200
commit23ec596abdbe08202da0c2e16ad385c0c43f79a2 (patch)
tree293eb2330fb68d39e3dac6293f604c30d9a7364e /dev-python/smmap2/smmap2-2.0.3.ebuild
parentdev-python/testpath: Version bump to 0.3.1 (diff)
downloadgentoo-23ec596abdbe08202da0c2e16ad385c0c43f79a2.tar.gz
gentoo-23ec596abdbe08202da0c2e16ad385c0c43f79a2.tar.bz2
gentoo-23ec596abdbe08202da0c2e16ad385c0c43f79a2.zip
dev-python/smmap2: Version bump to 2.0.3
Package-Manager: Portage-2.3.6, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5197
Diffstat (limited to 'dev-python/smmap2/smmap2-2.0.3.ebuild')
-rw-r--r--dev-python/smmap2/smmap2-2.0.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/smmap2/smmap2-2.0.3.ebuild b/dev-python/smmap2/smmap2-2.0.3.ebuild
new file mode 100644
index 000000000000..27eb3c7208c4
--- /dev/null
+++ b/dev-python/smmap2/smmap2-2.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of a sliding window memory map manager"
+HOMEPAGE="
+ https://pypi.python.org/pypi/smmap2
+ https://github.com/gitpython-developers/smmap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ !dev-python/smmap[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -v || die "tests failed under ${EPYTHON}"
+}