summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-28 06:01:17 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-28 06:19:27 +0100
commit1b61a05f2cd37178b9e098bcd1fdd4a6c0aef01b (patch)
tree498554c6d659cf3c5d37432da204a0c88adaa585 /dev-python/segno
parentdev-python/cryptography: Bump to 41.0.7 (diff)
downloadgentoo-1b61a05f2cd37178b9e098bcd1fdd4a6c0aef01b.tar.gz
gentoo-1b61a05f2cd37178b9e098bcd1fdd4a6c0aef01b.tar.bz2
gentoo-1b61a05f2cd37178b9e098bcd1fdd4a6c0aef01b.zip
dev-python/segno: Bump to 1.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/segno')
-rw-r--r--dev-python/segno/Manifest1
-rw-r--r--dev-python/segno/segno-1.6.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/segno/Manifest b/dev-python/segno/Manifest
index 65c98752a66e..13124bb1e399 100644
--- a/dev-python/segno/Manifest
+++ b/dev-python/segno/Manifest
@@ -1 +1,2 @@
DIST segno-1.5.3.gh.tar.gz 1632842 BLAKE2B 208c21db625bb7f3ace67e05b82988cc1e93e34147fa1cb8f070bad8312924aad8e62089ff6738995a3c725ee3d00bb56478896ab1b94067ce1c4bc58970982a SHA512 bdb933a7f4bac1189533199ac84cb729a3592474644deb0c28007c846d200bb08164052d83fbd6a1a82212401987ab393bfdd294f81360a4a8a0c88182a7623f
+DIST segno-1.6.0.gh.tar.gz 1631834 BLAKE2B c3dec021360fefbf55c90278a2eb8e4f26beda3b0297afabe662d5a8f2dede931f6caec6b7d514d610ce5fcfe2f8053862c88e360dbe88db4829e0efc3ef8342 SHA512 15e9f97caf202e03ef8399da96137774f4a0d6bb4ef0727eb026ff3d628665d8058cb2cc5562d1c63ad1b5613fcfdfc83e79991e896ee9b73304c3b22319707e
diff --git a/dev-python/segno/segno-1.6.0.ebuild b/dev-python/segno/segno-1.6.0.ebuild
new file mode 100644
index 000000000000..736d4d872b2e
--- /dev/null
+++ b/dev-python/segno/segno-1.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python QR Code and Micro QR Code encoder"
+HOMEPAGE="
+ https://pypi.org/project/segno/
+ https://github.com/heuer/segno/
+"
+SRC_URI="
+ https://github.com/heuer/segno/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pypng[${PYTHON_USEDEP}]
+ dev-python/pyzbar[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires qrcode-artistic
+ tests/test_plugin.py::test_plugin
+)