summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-10 10:13:20 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-10 10:58:10 +0200
commitfd8371af1880ddd6a05ffb6d873282b6cef8bc1a (patch)
treecbeab61e966651eb91fc8b99de5cadb244b164cc /dev-python/ruamel-yaml
parentdev-python/ruamel-yaml-clib: Switch to PEP517 build (diff)
downloadgentoo-fd8371af1880ddd6a05ffb6d873282b6cef8bc1a.tar.gz
gentoo-fd8371af1880ddd6a05ffb6d873282b6cef8bc1a.tar.bz2
gentoo-fd8371af1880ddd6a05ffb6d873282b6cef8bc1a.zip
dev-python/ruamel-yaml: PEP517, remove namespace dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ruamel-yaml')
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.21-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.21-r1.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.21-r1.ebuild
new file mode 100644
index 000000000000..004d9aa196d3
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.17.21-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="
+ https://pypi.org/project/ruamel.yaml/
+ https://sourceforge.net/projects/ruamel-yaml/
+"
+# PyPI tarballs do not include tests
+SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ _test/test_deprecation.py::test_collections_deprecation
+ )
+ local EPYTEST_IGNORE=(
+ # Old PyYAML tests from lib/ require special set-up and are
+ # invoked indirectly via test_z_olddata, tell pytest itself
+ # to leave the subdir alone.
+ _test/lib/
+ )
+
+ # this is needed to keep the tests working while
+ # dev-python/namespace-ruamel is still installed
+ cat > "${BUILD_DIR}/install$(python_get_sitedir)"/ruamel/__init__.py <<-EOF || die
+ __path__ = __import__('pkgutil').extend_path(__path__, __name__)
+ EOF
+ epytest
+ rm "${BUILD_DIR}/install$(python_get_sitedir)"/ruamel/__init__.py || die
+}