summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-12 08:44:41 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-12 08:45:07 +0200
commit888c4fcb2bd56530b4a4f16edaa1af26515a2416 (patch)
treef66d630e7ee604957a622ab4cf86e02b7be45e58 /dev-python/rsa/rsa-4.2.ebuild
parentdev-python/responses: Bump to 0.10.15 (diff)
downloadgentoo-888c4fcb2bd56530b4a4f16edaa1af26515a2416.tar.gz
gentoo-888c4fcb2bd56530b4a4f16edaa1af26515a2416.tar.bz2
gentoo-888c4fcb2bd56530b4a4f16edaa1af26515a2416.zip
dev-python/rsa: Bump to 4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rsa/rsa-4.2.ebuild')
-rw-r--r--dev-python/rsa/rsa-4.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/rsa/rsa-4.2.ebuild b/dev-python/rsa/rsa-4.2.ebuild
new file mode 100644
index 000000000000..30d113c5c598
--- /dev/null
+++ b/dev-python/rsa/rsa-4.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+MY_P=python-rsa-version-${PV}
+DESCRIPTION="Pure-Python RSA implementation"
+HOMEPAGE="https://stuvel.eu/rsa https://pypi.org/project/rsa/"
+SRC_URI="
+ https://github.com/sybrenstuvel/python-rsa/archive/version-${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/pyasn1-0.1.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ rm tests/test_mypy.py || die
+ distutils-r1_src_prepare
+}