summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-07 08:35:51 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-07 09:21:07 +0200
commit667ac1ac15bf3d4d3313fc6681dd3888da25b3ce (patch)
tree730dee38ffeecfe0bd58ef6c1987fc57396e4c2d /dev-python/rich
parentdev-python/Faker: Bump to 9.0.0 (diff)
downloadgentoo-667ac1ac15bf3d4d3313fc6681dd3888da25b3ce.tar.gz
gentoo-667ac1ac15bf3d4d3313fc6681dd3888da25b3ce.tar.bz2
gentoo-667ac1ac15bf3d4d3313fc6681dd3888da25b3ce.zip
dev-python/rich: Bump to 10.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-10.12.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 0fc9352eaecc..1de6c995c438 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,2 +1,3 @@
DIST rich-10.10.0.tar.gz 16264680 BLAKE2B 5f57b7ea7a091b3478ddc17dfe29309f558f36e8795a66ea918141f42f2a9e5a655667a1db8420193f3f44ba070413ebb512601751a6a5663a87db775576ce65 SHA512 8b9f1348b0f55db90c17042a83e8317d4f00b5446a77334a12379676ef1fe526f40dc92425e4bafce22ee5f65bcb2fae2422b903c6f958feb5734c254813826e
DIST rich-10.11.0.tar.gz 16266050 BLAKE2B 34081a127eacbc875fb5af1b00a195df4718eacb4e0371ac1367950fc8e102bc2a611d970364a1b02cb400137cb838aa30d9bcd757a4d4644ed976c49c9603c8 SHA512 34cdcad401dbda0763dfaa6f46e19e498b2da96ed9423a00a957d55f9e2833fabc6b2e6d65e411dcb5814c869a8670b5242e1a891835d6b6675d4da86b28f33d
+DIST rich-10.12.0.tar.gz 16265099 BLAKE2B c2249be5a5008e3e9fd5c301b10d7bc544e4805d4762e87481aa31716e38eb3cb2b81ce80f201fc0d3961574136f47b7b374d6bc7d18e4f55f1f757a7e17e5a2 SHA512 bb42ff24c9eeeae548a6e222ecc03f8b46d763c4b022964bd8fb11517f1a23a7aaa82a2155d5cd3d29cdd1af5fab6cc4f26840a84ce5e26dd740f8706961ce1f
diff --git a/dev-python/rich/rich-10.12.0.ebuild b/dev-python/rich/rich-10.12.0.ebuild
new file mode 100644
index 000000000000..05ddc3dab2e6
--- /dev/null
+++ b/dev-python/rich/rich-10.12.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/willmcgugan/rich"
+SRC_URI="https://github.com/willmcgugan/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}