summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-02 11:46:51 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-02 13:22:34 +0200
commitc1d62c558d458d87893572f9acbd40eca42a76f8 (patch)
tree9bcd8f66cc2ff586068a76bd208f80409b3d0343 /dev-python/reportlab
parentdev-python/pymdown-extensions: Bump to 10.11.2 (diff)
downloadgentoo-c1d62c558d458d87893572f9acbd40eca42a76f8.tar.gz
gentoo-c1d62c558d458d87893572f9acbd40eca42a76f8.tar.bz2
gentoo-c1d62c558d458d87893572f9acbd40eca42a76f8.zip
dev-python/reportlab: Bump to 4.2.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/reportlab')
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/reportlab-4.2.5.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index 2685ee1f7e52..cbce4a8bdcc6 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -1,3 +1,4 @@
DIST pfbfer-20070710.zip 677333 BLAKE2B 100214476a361a5e5d1f3da0999591345f6e3a3f8c6bc3f6a3e9eca734190c6259758a43302c6e41254d33491fe535eb7d5dd07aa9727c912424bebc31fc18df SHA512 6fd4a5d955464b10d13a7b748703450c1fe120d5ed09e8cfa1b4dfa9c183c59fe001df29433af551796b0df62544b7ddc364f9bb1bdcc2cd300434340ffcc4f2
DIST reportlab-4.2.2.tar.gz 3690306 BLAKE2B 1f778d25cb02f918758db13f27e380db4d0082c79c534699840e760a54ccb40c1d8bffc51b66de1f79030458ab9d48df7464a40a0a154382f1d02534696f7701 SHA512 4dc7a414ea32a741f660f523d14605fb46410d844d3be60b9f6d39642c0a7ad6162fa4b7448eba650b087a31e40e0ff7fc0bb5eb416dbbaeb104c416285a438d
DIST reportlab-4.2.4.tar.gz 3581357 BLAKE2B 3a06bde9bba5f057dd895929186d70ea1eb66c458aec380c10fff6ada557c2037664085881fffd7781c5148ea526c9e77a5dbf6b42fae5dfda2583063ff23d52 SHA512 ad6754d6142ea43b4f160d6eecbede83d8bc4f3dfc7822fc0de9e39d357370c43c8fe43ae6603a117c9b8b5cf354e925673567cf01883a0401b881b354352a3c
+DIST reportlab-4.2.5.tar.gz 3581379 BLAKE2B 560175a5180f3e991a3bed26f40b1c73b80a0f7dde9a30be2693ca0008d5272a3c1903fa930112e5f023e433a45c6ce384f9f239335c12400434a390a25ca501 SHA512 1daf01a03dd12770d40dbc1be66f0128a63953eebc97175d5cdf9a30cc6f827bc7a50e4f12cf0def8edecd3798fdc1fe009b3b92b0a252ca8a1395f83d6e970f
diff --git a/dev-python/reportlab/reportlab-4.2.5.ebuild b/dev-python/reportlab/reportlab-4.2.5.ebuild
new file mode 100644
index 000000000000..4c2de91a5490
--- /dev/null
+++ b/dev-python/reportlab/reportlab-4.2.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source"
+HOMEPAGE="
+ https://www.reportlab.com/
+ https://pypi.org/project/reportlab/
+"
+SRC_URI+="
+ https://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pillow[tiff,truetype,jpeg(+),${PYTHON_USEDEP}]
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+distutils_enable_sphinx docs/source
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+src_configure() {
+ cat > local-setup.cfg <<-EOF || die
+ [OPTIONS]
+ no-download-t1-files = 1
+ EOF
+}
+
+python_test() {
+ pushd tests >/dev/null || die
+ "${EPYTHON}" runAll.py --post-install --verbosity=2 ||
+ die "Testing failed with ${EPYTHON}"
+ popd >/dev/null || die
+}