summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/regex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/regex')
-rw-r--r--dev-python/regex/Manifest2
-rw-r--r--dev-python/regex/metadata.xml9
-rw-r--r--dev-python/regex/regex-2015.06.24.ebuild39
-rw-r--r--dev-python/regex/regex-2015.07.12.ebuild39
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/regex/Manifest b/dev-python/regex/Manifest
new file mode 100644
index 000000000000..6bf60d6aa3ab
--- /dev/null
+++ b/dev-python/regex/Manifest
@@ -0,0 +1,2 @@
+DIST regex-2015.06.24.tar.gz 553785 SHA256 97dbcbe9a1c247ba351b926b0683b5fec82260e7ea649ab51087bb58ad00275a SHA512 570320e5c74793246da77f8b85b623604698d187780121d30a3d5a53f410bc998c48481bfef6245c546a6e6950020a2905f3b5fd3be33964de92af73c4acc1a7 WHIRLPOOL 37704652ebdc5f09c13960acbc7a4c890b1a0bdceab9d6e4b9053a3bb99ec1b54462667cf17960ccccf091bd64d49d19cc079e187b5af1e40d8b1d155053f202
+DIST regex-2015.07.12.tar.gz 554160 SHA256 9a39618645ce8c707c2c1346a3eeef0e441a9084df0739a5fcfe32059f68ebe1 SHA512 3b8cfa029744d17f06c659e6357d3a4520817656da6dcfc6952bbdac01fec266e8832fab649000fc7a3dacab508e2ae462728c139cc4cac913c40e2ae34abf54 WHIRLPOOL 86f004c6d8533071ef938ba39cfe34f198dcc56ab75883f8b5f2bc2dfaa40abc46b0ed64aa873821c6cc4e694c424dd8a16d97c35a6a1fafa7d2f84e09c59adf
diff --git a/dev-python/regex/metadata.xml b/dev-python/regex/metadata.xml
new file mode 100644
index 000000000000..bea963872644
--- /dev/null
+++ b/dev-python/regex/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">regex</remote-id>
+ <remote-id type="bitbucket">mrabarnett/mrab-regex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/regex/regex-2015.06.24.ebuild b/dev-python/regex/regex-2015.06.24.ebuild
new file mode 100644
index 000000000000..fd300192e5a6
--- /dev/null
+++ b/dev-python/regex/regex-2015.06.24.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Alternative regular expression module to replace re"
+HOMEPAGE="https://bitbucket.org/mrabarnett/mrab-regex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+DOCS=( README docs/Features.rst docs/UnicodeProperties.txt )
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local msg="tests failed under ${EPYTHON}"
+ # https://bitbucket.org/mrabarnett/mrab-regex/issue/145/1-fail-in-testsuite-under-pypy
+ einfo "There is one trivial fail of test test_empty_array under pypy"
+
+ if python_is_python3; then
+ "${PYTHON}" Python3/test_regex.py || die $msg
+ else
+ "${PYTHON}" Python2/test_regex.py || die $msg
+ fi
+}
diff --git a/dev-python/regex/regex-2015.07.12.ebuild b/dev-python/regex/regex-2015.07.12.ebuild
new file mode 100644
index 000000000000..fd300192e5a6
--- /dev/null
+++ b/dev-python/regex/regex-2015.07.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Alternative regular expression module to replace re"
+HOMEPAGE="https://bitbucket.org/mrabarnett/mrab-regex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+DOCS=( README docs/Features.rst docs/UnicodeProperties.txt )
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local msg="tests failed under ${EPYTHON}"
+ # https://bitbucket.org/mrabarnett/mrab-regex/issue/145/1-fail-in-testsuite-under-pypy
+ einfo "There is one trivial fail of test test_empty_array under pypy"
+
+ if python_is_python3; then
+ "${PYTHON}" Python3/test_regex.py || die $msg
+ else
+ "${PYTHON}" Python2/test_regex.py || die $msg
+ fi
+}