summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-26 12:39:19 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-26 13:10:08 +0200
commit0cd1801bd21c0e9413b10e3035203312a855ed4c (patch)
tree08beac5dc9670d58fb9f1c8a311081144f84cf1c /dev-python/rapidfuzz
parentdev-python/jarowinkler: Bump to 1.2.2 (diff)
downloadgentoo-0cd1801bd21c0e9413b10e3035203312a855ed4c.tar.gz
gentoo-0cd1801bd21c0e9413b10e3035203312a855ed4c.tar.bz2
gentoo-0cd1801bd21c0e9413b10e3035203312a855ed4c.zip
dev-python/rapidfuzz: Bump to 2.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rapidfuzz')
-rw-r--r--dev-python/rapidfuzz/Manifest1
-rw-r--r--dev-python/rapidfuzz/rapidfuzz-2.10.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/rapidfuzz/Manifest b/dev-python/rapidfuzz/Manifest
index f1d4562c8239..f7e7df30c549 100644
--- a/dev-python/rapidfuzz/Manifest
+++ b/dev-python/rapidfuzz/Manifest
@@ -1,2 +1,3 @@
DIST rapidfuzz-2.10.0.tar.gz 782698 BLAKE2B f2b4ead136162fd3592b16978a58cd3a2d66489f05aefdf58fd137ebf34f347368f437b3ee836b36122b00863f0c238c8191307f6b586676db59ebfa2d370e1c SHA512 b704a535021924e436a1cebe397e747d3e39b6a4ec12718bbb2a91c326d1977c51bd7ca9a4b2c2d380fdc27ea76b1549d61dea511ed86054aceb1d2180716627
+DIST rapidfuzz-2.10.1.tar.gz 782833 BLAKE2B a8be0ad8c617d8389b5fd22bff06e3887665dedd73580ac6ed29c3f5b895c399ffa0ac6ea983cb0a12d279d5312514e645f75d1a09a40be7108097b74e78c2d5 SHA512 006c714c4c2b86d77682042c7bd3e7a19328a56ff12b42f01e96712c4a94db654d63607363cf68b746416f107927bdee9dee9d7d29c80eda7c7fa74e0c21b75d
DIST rapidfuzz-2.9.0.tar.gz 780939 BLAKE2B c43dfd89d18dc1f5b4738930f1d0d9c4956f66479217b4400844b50636e2b0bb13f15d8b9a6edc0ce30fc943f35a44dad802ecf90107556ed2dee7f70fcc16ac SHA512 b8f83cc35e84a4ed95e2086eb7bfbc6e7e2e25a05accc965092b8b51012c79e86e2af15397577bb91aadfa9a257a62d6f3d6bb9bf928a9c767d53468904a12be
diff --git a/dev-python/rapidfuzz/rapidfuzz-2.10.1.ebuild b/dev-python/rapidfuzz/rapidfuzz-2.10.1.ebuild
new file mode 100644
index 000000000000..3a1dc1af36a6
--- /dev/null
+++ b/dev-python/rapidfuzz/rapidfuzz-2.10.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# custom wrapper over setuptools
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Rapid fuzzy string matching in Python using various string metrics"
+HOMEPAGE="
+ https://github.com/maxbachmann/RapidFuzz/
+ https://pypi.org/project/rapidfuzz/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ <dev-python/jarowinkler-2[${PYTHON_USEDEP}]
+ >=dev-python/jarowinkler-1.2.2[${PYTHON_USEDEP}]
+"
+# all these are header-only libraries
+DEPEND="
+ >=dev-cpp/taskflow-3.0.0
+ >=dev-cpp/jarowinkler-cpp-1.0.0
+ >=dev-cpp/rapidfuzz-cpp-1.0.1
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/rapidfuzz_capi[${PYTHON_USEDEP}]
+ >=dev-python/scikit-build-0.13.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export RAPIDFUZZ_BUILD_EXTENSION=1