summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-07 16:28:52 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-07 16:59:48 +0100
commita5c5181456bed1eb1ac4423e19b5db2d7a383478 (patch)
tree39e9a76b653d2e9dc6435850ef73e86333795185 /dev-python/pyupgrade
parentdev-python/flatbuffers: Add python@ as co-maint. (diff)
downloadgentoo-a5c5181456bed1eb1ac4423e19b5db2d7a383478.tar.gz
gentoo-a5c5181456bed1eb1ac4423e19b5db2d7a383478.tar.bz2
gentoo-a5c5181456bed1eb1ac4423e19b5db2d7a383478.zip
dev-python/pyupgrade: Bump to 3.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyupgrade')
-rw-r--r--dev-python/pyupgrade/Manifest1
-rw-r--r--dev-python/pyupgrade/pyupgrade-3.3.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyupgrade/Manifest b/dev-python/pyupgrade/Manifest
index f275e86744b7..ac4c438bbfc4 100644
--- a/dev-python/pyupgrade/Manifest
+++ b/dev-python/pyupgrade/Manifest
@@ -1,3 +1,4 @@
DIST pyupgrade-3.2.2.gh.tar.gz 62261 BLAKE2B 8a34b01c3eacb004c73a56f4437223ddbb4ddbaed7dcb03f532f877954abcf589739c1a4afadd7b14db6b120039bead6dba551b59cb03e94a99d18bb9f503f45 SHA512 1586dd38eff08ee0a0fb4d8db77593d965d5f675893a6cd23e6de7bf966d2f087013c1deeeab47e88af9162929d6ee110d29cf00041189c9715c2395c1b3798b
DIST pyupgrade-3.2.3.gh.tar.gz 62349 BLAKE2B 5e698f25ad846503e562219a192841912c4581cdd3b663b3b982d7923b774b63cd2ab8666b25c6c2945bd3a823fb3138f795829cda2f2e3f8046a2f882061dde SHA512 14dc0856a035a14cca7250ee99b7c001ad39cfd648ea04900e266d611ab7fe89bff6f678c14df4f43dd264146116c5a4190167b6c74506bc82c46b80863372c9
DIST pyupgrade-3.3.0.gh.tar.gz 62628 BLAKE2B 18af1a3efe49d78524f35762f35a6933876f0b21775b84eae8acb95b38681861a8a1a3009c76ade8364ead9e35cf592eb664f31f61e4af5014207460f90b5f0c SHA512 f6a37c8e35f44ddf0154714ca13ab7b322fe38d629234898faa2a435b4ce8eef0e18f7407af20f9c5fd6afe6a6392755cfc301714c1789cb55896fd2247cb7b4
+DIST pyupgrade-3.3.1.gh.tar.gz 62720 BLAKE2B e1b1d899bb46871f0a28ac3423efbcbd91e0bbdac2ab3054fc19434c67a8702e4967d3cd7674284022e7b7847dc947c8d1736eeee78d8a9416de2b7c25eae715 SHA512 1f062a884061e77ec11e6dd1cc1bedd2680b443b1268b30a9f6bfa2954ef3ff8a6dd1108abdb3a9b0acc937456fe6621a5ad3b9e9ad5c1696e95d0903859ff5f
diff --git a/dev-python/pyupgrade/pyupgrade-3.3.1.ebuild b/dev-python/pyupgrade/pyupgrade-3.3.1.ebuild
new file mode 100644
index 000000000000..02368726bb1d
--- /dev/null
+++ b/dev-python/pyupgrade/pyupgrade-3.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool + pre-commit hook to automatically upgrade syntax for newer Pythons"
+HOMEPAGE="
+ https://github.com/asottile/pyupgrade/
+ https://pypi.org/project/pyupgrade/
+"
+SRC_URI="
+ https://github.com/asottile/pyupgrade/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/tokenize-rt[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest