summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-11 06:07:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-11 07:17:54 +0200
commit24600a51a8b2ad254613ce89475acc938da97832 (patch)
tree221fa548be9df9d7e51736ae9546f8fe35e15a50 /dev-python/pyupgrade
parentdev-libs/miniaudio: Keyword 0.11.15 x86, #908285 (diff)
downloadgentoo-24600a51a8b2ad254613ce89475acc938da97832.tar.gz
gentoo-24600a51a8b2ad254613ce89475acc938da97832.tar.bz2
gentoo-24600a51a8b2ad254613ce89475acc938da97832.zip
dev-python/pyupgrade: Bump to 3.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyupgrade')
-rw-r--r--dev-python/pyupgrade/Manifest1
-rw-r--r--dev-python/pyupgrade/pyupgrade-3.6.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyupgrade/Manifest b/dev-python/pyupgrade/Manifest
index c3fff241583c..c632f19fbcc0 100644
--- a/dev-python/pyupgrade/Manifest
+++ b/dev-python/pyupgrade/Manifest
@@ -1,3 +1,4 @@
DIST pyupgrade-3.3.1.gh.tar.gz 62720 BLAKE2B e1b1d899bb46871f0a28ac3423efbcbd91e0bbdac2ab3054fc19434c67a8702e4967d3cd7674284022e7b7847dc947c8d1736eeee78d8a9416de2b7c25eae715 SHA512 1f062a884061e77ec11e6dd1cc1bedd2680b443b1268b30a9f6bfa2954ef3ff8a6dd1108abdb3a9b0acc937456fe6621a5ad3b9e9ad5c1696e95d0903859ff5f
DIST pyupgrade-3.3.2.gh.tar.gz 62698 BLAKE2B 5dc1d9e9ea7b91cb2835ffdbc109fb4fcde629f375c49714cf52fe779b20a61f38f13321a14803636e759ac8a4460e768c4173c6608da1cf7cd44a3a347660e9 SHA512 6436286a9398d9cae8c5e9cff2104c43638cafb866a1b97794c1d20cadc078ae5a657d1b83512461d20d2f581b8f8fbbb2ee4d0516f8e75d562c5934be4966e5
DIST pyupgrade-3.4.0.gh.tar.gz 62408 BLAKE2B a816cea1e2b17790312d4e17ec972a1e09a0dd81c6fe4f7eb28c686b39b468b84190b26cf9ae5a711f70f8c1213c0b472975cc76339f64d2af4b4a8593af6b79 SHA512 cf9b8d8b430949eb0b49ec1b28576db7d6932c83a727660fe5e2cd61ae32e3efba63120580e0184931e3fdd4a4913a0f9cb37984ca83adeab05ab3ca57107b27
+DIST pyupgrade-3.6.0.gh.tar.gz 62595 BLAKE2B a6622985e4b26bfb55cdeebd2323bd912289399bffa167b7d4ac1d16c11072b9b58793193febed31838d72691f3c6882914cd7005391f477a2ca6c78b808a33d SHA512 15b3ea59e0afbd5da0c2e7d60ed938d418107eb99cae7d2a5059fcea3f3ea69f451fed962cbdbb40655c39911c92f21bb9ace55f9b1bc65be2f8870b5b48acb8
diff --git a/dev-python/pyupgrade/pyupgrade-3.6.0.ebuild b/dev-python/pyupgrade/pyupgrade-3.6.0.ebuild
new file mode 100644
index 000000000000..8d3990592700
--- /dev/null
+++ b/dev-python/pyupgrade/pyupgrade-3.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool + pre-commit hook to automatically upgrade syntax for newer Pythons"
+HOMEPAGE="
+ https://github.com/asottile/pyupgrade/
+ https://pypi.org/project/pyupgrade/
+"
+# no tests in sdist, as of 3.3.2
+SRC_URI="
+ https://github.com/asottile/pyupgrade/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/tokenize-rt[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest