summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2017-04-14 23:03:49 +0200
committerCédric Krier <cedk@gentoo.org>2017-04-14 23:03:49 +0200
commite9c18c85213f7d0b04a3ab23d90e14a51797dfb8 (patch)
tree8eef329be5818754ca57dc0928794886807c6944 /dev-python/python-stdnum/python-stdnum-1.6.ebuild
parentnet-libs/libsearpc: remove broken ebuild. (diff)
downloadgentoo-e9c18c85213f7d0b04a3ab23d90e14a51797dfb8.tar.gz
gentoo-e9c18c85213f7d0b04a3ab23d90e14a51797dfb8.tar.bz2
gentoo-e9c18c85213f7d0b04a3ab23d90e14a51797dfb8.zip
dev-python/python-stdnum: Version bumps
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/python-stdnum/python-stdnum-1.6.ebuild')
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.6.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/python-stdnum-1.6.ebuild b/dev-python/python-stdnum/python-stdnum-1.6.ebuild
new file mode 100644
index 000000000000..f2da42e2503a
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="http://arthurdejong.org/python-stdnum/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies test"
+
+RDEPEND="vies? ( dev-python/suds )"
+DEPEND="${DEPEND}
+ dev-python/setuptools
+ test? ( dev-python/nose )"
+
+DOCS=( ChangeLog NEWS README )
+
+python_test() {
+ nosetests || die
+}