summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-05-08 22:25:45 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-05-08 22:31:01 +0300
commitc8d1f0ecc2480c98c48e7a08f7946fcd9d986fe0 (patch)
treefc954fa9b854ad52a82a1cad43855f1d5fcfd004 /dev-python/python-socks
parentdev-python/ipykernel: add 6.23.0 (diff)
downloadgentoo-c8d1f0ecc2480c98c48e7a08f7946fcd9d986fe0.tar.gz
gentoo-c8d1f0ecc2480c98c48e7a08f7946fcd9d986fe0.tar.bz2
gentoo-c8d1f0ecc2480c98c48e7a08f7946fcd9d986fe0.zip
dev-python/python-socks: add 2.3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python-socks')
-rw-r--r--dev-python/python-socks/Manifest1
-rw-r--r--dev-python/python-socks/python-socks-2.3.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index 30d0922655fa..849aff1c8ae8 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1 +1,2 @@
DIST python-socks-2.2.0.gh.tar.gz 32483 BLAKE2B 44dba93f29b3466515591bced694b1f17a76d7a9410829f8d4cfe0c4da18b00dddb9a84b37a9ce74dd20517a3567c06f4b96e4cc4724e88244dd11b097b3da9e SHA512 7189a249fcbc80c13f6070cd82d785ca4be48cbaf0a0e37da486b8517f551b9a22678a0c4d65f98adb30c719b5f47a3e9cd0133633a429283b04cdae089ed6a6
+DIST python-socks-2.3.0.gh.tar.gz 32506 BLAKE2B 0eaddbb4400488b6c96458d84671e69c9dd9bf927b9ea830d4161d4d78bdc32f66fb0c02f19e63afa868bd248a95d1544463bc877b79fd533b3952bfc71bef52 SHA512 792489d9daa63847733580b36d85d143146d0cd0b3f29297fa732516dea203b3f82deaf2779b56d80c20abe2739ed79e28a9a21cfeb26768ec557efef34c74f7
diff --git a/dev-python/python-socks/python-socks-2.3.0.ebuild b/dev-python/python-socks/python-socks-2.3.0.ebuild
new file mode 100644
index 000000000000..71600c1a9cbc
--- /dev/null
+++ b/dev-python/python-socks/python-socks-2.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://github.com/romis2012/python-socks/
+ https://pypi.org/project/python-socks/
+"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# curio is not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+# TODO: revisit
+RDEPEND="
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/tiny-proxy-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.16.0[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+# Test markers exist to exclude trio etc if needed
+distutils_enable_tests pytest