summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-31 08:43:47 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-31 08:52:42 +0100
commitfebf8920c1c6408904277d9da5e55147d79ec0cb (patch)
treee3aae4daebf092763935c54b26998d7e1092333c /dev-python/python-lsp-black
parentdev-python/natsort: Bump to 8.1.0 (diff)
downloadgentoo-febf8920c1c6408904277d9da5e55147d79ec0cb.tar.gz
gentoo-febf8920c1c6408904277d9da5e55147d79ec0cb.tar.bz2
gentoo-febf8920c1c6408904277d9da5e55147d79ec0cb.zip
dev-python/python-lsp-black: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-lsp-black')
-rw-r--r--dev-python/python-lsp-black/Manifest1
-rw-r--r--dev-python/python-lsp-black/python-lsp-black-1.1.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-lsp-black/Manifest b/dev-python/python-lsp-black/Manifest
index 96fdf9956052..2a67d803d243 100644
--- a/dev-python/python-lsp-black/Manifest
+++ b/dev-python/python-lsp-black/Manifest
@@ -1 +1,2 @@
DIST python-lsp-black-1.0.1.gh.tar.gz 7013 BLAKE2B 596ef3f468524269fb2765ad7ba0f8305c9e67ec4cf826dbe68ea20058f1fc595c004b34c5228c14a70b6a489e29f370fef93cd7a9ef48d24ace3464ec7cd011 SHA512 43699438bf64b9cfb5dfa97b30385870a06d15be90d5a023c5282f1b969188e8536961c2a2ee6f1016d4b8188e4df6a81d6127dd628242bbcd3fbcc640504a24
+DIST python-lsp-black-1.1.0.gh.tar.gz 7547 BLAKE2B e362e3800763b28c9505e9548f2324299fac5db792cc98755b2f3e5db02cec3cf0061193aa5dda40a843f2db0abfc252b8ebf6ae12a403953bb334155e90b028 SHA512 47c1652e7c1732a01d0eaa29c3b36adaa484b4b61aed8f6a99967c734d43353173716946cd15ea247974ee7801daa57e34979f5ed9b52eb88fdf96830af8bd19
diff --git a/dev-python/python-lsp-black/python-lsp-black-1.1.0.ebuild b/dev-python/python-lsp-black/python-lsp-black-1.1.0.ebuild
new file mode 100644
index 000000000000..c51ae83262ae
--- /dev/null
+++ b/dev-python/python-lsp-black/python-lsp-black-1.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Black plugin for the Python LSP Server"
+HOMEPAGE="https://github.com/python-lsp/python-lsp-black
+ https://pypi.org/project/python-lsp-black/"
+SRC_URI="https://github.com/python-lsp/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/python-lsp-server[${PYTHON_USEDEP}]
+ >=dev-python/black-19[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest