summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-09 17:10:07 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-09 22:34:00 +0200
commitd407796fb54195a8b8568cc4c76d6f2d3f8ac9f9 (patch)
tree9e69df328cc98ce12e8fd98709fe51fa8dc1d8ab /dev-python/pytest
parentdev-python/py: Enable py3.11 (diff)
downloadgentoo-d407796fb54195a8b8568cc4c76d6f2d3f8ac9f9.tar.gz
gentoo-d407796fb54195a8b8568cc4c76d6f2d3f8ac9f9.tar.bz2
gentoo-d407796fb54195a8b8568cc4c76d6f2d3f8ac9f9.zip
dev-python/pytest: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/pytest-7.1.2.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/dev-python/pytest/pytest-7.1.2.ebuild b/dev-python/pytest/pytest-7.1.2.ebuild
index edb8937ece04..1143038d9a5b 100644
--- a/dev-python/pytest/pytest-7.1.2.ebuild
+++ b/dev-python/pytest/pytest-7.1.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1 multiprocessing
@@ -35,14 +35,16 @@ BDEPEND="
>=dev-python/setuptools_scm-6.2.3[${PYTHON_USEDEP}]
test? (
${RDEPEND}
- dev-python/argcomplete[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.7.2[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/xmlschema[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.7.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ ' python3_{8..10} pypy3)
)
"
@@ -54,6 +56,11 @@ src_test() {
}
python_test() {
+ if ! has "${EPYTHON}" python3.{8..10} pypy3; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x COLUMNS=80