summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-12 14:47:20 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-12 15:14:47 +0200
commit553810bbed871008b7e6fd1f625eee0b16e6bb7f (patch)
tree263c537876df7121997c5af585d09bc6dc917477 /dev-python/pytest-shutil
parentdev-python/termcolor: Enable py3.11 (diff)
downloadgentoo-553810bbed871008b7e6fd1f625eee0b16e6bb7f.tar.gz
gentoo-553810bbed871008b7e6fd1f625eee0b16e6bb7f.tar.bz2
gentoo-553810bbed871008b7e6fd1f625eee0b16e6bb7f.zip
dev-python/pytest-shutil: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-shutil')
-rw-r--r--dev-python/pytest-shutil/pytest-shutil-1.7.0-r3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pytest-shutil/pytest-shutil-1.7.0-r3.ebuild b/dev-python/pytest-shutil/pytest-shutil-1.7.0-r3.ebuild
new file mode 100644
index 000000000000..93f3616ac970
--- /dev/null
+++ b/dev-python/pytest-shutil/pytest-shutil-1.7.0-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A goodie-bag of unix shell and environment tools for py.test"
+HOMEPAGE="
+ https://github.com/man-group/pytest-plugins/
+ https://pypi.org/project/pytest-shutil/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+"
+# block pytest plugins that will be broken by the upgrade
+RDEPEND+="
+ !<dev-python/pytest-virtualenv-1.7.0-r1[python_targets_python2_7(-)]
+"
+
+BDEPEND="
+ ${RDEPEND}
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove unnecessary deps
+ # (contextlib2 is not used in py3)
+ sed -i -e '/path\.py/d' -e '/contextlib2/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}