summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-28 19:41:51 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-28 19:48:47 +0100
commit06c29c5e48d51d6e557fb71749b68203c8df8ec3 (patch)
tree959785dc6bf94af34e6281134b0f73892c6f3280 /dev-python/pytest-pylint
parentdev-python/pytest-pep8: Remove redundant versions (diff)
downloadgentoo-06c29c5e48d51d6e557fb71749b68203c8df8ec3.tar.gz
gentoo-06c29c5e48d51d6e557fb71749b68203c8df8ec3.tar.bz2
gentoo-06c29c5e48d51d6e557fb71749b68203c8df8ec3.zip
dev-python/pytest-pylint: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-pylint')
-rw-r--r--dev-python/pytest-pylint/Manifest1
-rw-r--r--dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild38
2 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/pytest-pylint/Manifest b/dev-python/pytest-pylint/Manifest
index 55fbdf4eb1fd..0c5391f7428a 100644
--- a/dev-python/pytest-pylint/Manifest
+++ b/dev-python/pytest-pylint/Manifest
@@ -1,2 +1 @@
DIST pytest-pylint-0.14.1.tar.gz 8144 BLAKE2B d78892e3e606ec588b48a252db447e1cc76e27e45606670da3a3acddf040485004a7af84474732b044fdbf80ad760c07fda5e35030b9b2c9e5ce89f4809529c2 SHA512 697cd40e8e4c3722e382c7fd2dbebcb1728675e35b60396628576ec09735595af56431a2c080f29a2f35f304d912c80e4afdf0f8bd21a3adeae3156b9e58c751
-DIST pytest-pylint-0.7.1.tar.gz 5648 BLAKE2B 0baf011d9bbcfc5e66b8ea2c4fd95c8a3f8bbeedca15e2ec35d36b372b410d87ba619b0938acb26c667750c2f81d4bb09ca688731f9e184877fd999be04b6f26 SHA512 e2a7802f90ea25a909094e8bc67570eb631d6ab6dc130bb5cca1738ae09d069b4fa6c3c1349d9d62188a924138e832a3a37c8c5c8964290c95d69eecbadbd09f
diff --git a/dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild b/dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild
deleted file mode 100644
index b9736d3679cf..000000000000
--- a/dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1
-
-DESCRIPTION="pytest plugin to check source code with pylint"
-HOMEPAGE="https://github.com/carsongee/pytest-pylint"
-SRC_URI="https://github.com/carsongee/pytest-pylint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-pep8[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # pytest grabs the options from tox.ini automatically
- # but setup.py does not declare pytest-pep8 as a dep,
- # so it's missing from env created by distutils_install_for_testing
- sed -i -e 's:--pep8::' tox.ini || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
- py.test -v || die "Tests fail with ${EPYTHON}"
-}