summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-18 07:40:05 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-18 08:04:26 +0200
commitcaf722acd34019ed504c4cc08ac742cd072cde81 (patch)
tree6cf103225931959c8beaabefc03ca8a24e84ce49 /dev-python/pytest-localserver
parentdev-python/aiohttp: Bump to 3.10.4 (diff)
downloadgentoo-caf722acd34019ed504c4cc08ac742cd072cde81.tar.gz
gentoo-caf722acd34019ed504c4cc08ac742cd072cde81.tar.bz2
gentoo-caf722acd34019ed504c4cc08ac742cd072cde81.zip
dev-python/pytest-localserver: Bump to 0.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-localserver')
-rw-r--r--dev-python/pytest-localserver/Manifest1
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.9.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pytest-localserver/Manifest b/dev-python/pytest-localserver/Manifest
index 569befd320f9..5a14b26ec6f7 100644
--- a/dev-python/pytest-localserver/Manifest
+++ b/dev-python/pytest-localserver/Manifest
@@ -1 +1,2 @@
DIST pytest-localserver-0.8.1.tar.gz 29088 BLAKE2B 9872d9992a7a19af03bfd7fe748c42cee1daaf7789d4984582c901471eaeab7f1bcf5c21f8eed364c71805fe776f1e4053c6044cd00c333d213ef523b6d0bac4 SHA512 d0707d70b3c5caf346c7461cfca203f903277458596839cc2b1d1d48b6d1e6252e51ebcb9c21dc28fd3b98ce8368cb38e771c2a4226a5fc1dec4007f0b243cc2
+DIST pytest_localserver-0.9.0.tar.gz 30222 BLAKE2B b452ef71045c8a157035d56a17f1debee15ee63ca3912d44c90e691b744216a2375980f728bb1d33ee41c527c7115ea975299d7d567b23a1ca1c5ce2dcf41dd7 SHA512 15aa2db9d5a9ca841499d455de7002cd2cb6288c165605f44bb88d5ce3e06b9ce02eacd226853734017fe41075e1cfcdd5cd5c422ee240086ef0cf95fc450011
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.9.0.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.9.0.ebuild
new file mode 100644
index 000000000000..4b5bc4f214e2
--- /dev/null
+++ b/dev-python/pytest-localserver/pytest-localserver-0.9.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin to test server connections locally"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-localserver/
+ https://pypi.org/project/pytest-localserver/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # requires aiosmtpd that is dead and broken beyond repair
+ tests/test_smtp.py
+)
+
+src_prepare() {
+ # remove aiosmtpd dep
+ sed -e '/aiosmtpd/d' -i setup.py || die
+ distutils-r1_src_prepare
+}