summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-05 07:48:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-05 07:48:20 +0300
commit1dd5b1c282fc17b5ad8a75527339237f73e6237f (patch)
treef22be31f1e25a306ee33d8948270341a8fb0195e /dev-python/pytest-localftpserver
parentmedia-gfx/prusaslicer: update HOMEPAGE (diff)
downloadgentoo-1dd5b1c282fc17b5ad8a75527339237f73e6237f.tar.gz
gentoo-1dd5b1c282fc17b5ad8a75527339237f73e6237f.tar.bz2
gentoo-1dd5b1c282fc17b5ad8a75527339237f73e6237f.zip
dev-python/pytest-localftpserver: add 1.1.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-localftpserver')
-rw-r--r--dev-python/pytest-localftpserver/Manifest1
-rw-r--r--dev-python/pytest-localftpserver/pytest-localftpserver-1.1.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-localftpserver/Manifest b/dev-python/pytest-localftpserver/Manifest
index bdbd45a48e8c..58904c831603 100644
--- a/dev-python/pytest-localftpserver/Manifest
+++ b/dev-python/pytest-localftpserver/Manifest
@@ -1 +1,2 @@
DIST pytest_localftpserver-1.1.3.tar.gz 44510 BLAKE2B 98085adc5dd31bb6556ea1f31c6342e8453a07c24658baf5fe94e91a001e9b88c5f6ef01a3a8419bd7b1bd3eb053ef52788c80926c5984b523d9f575224ff6ec SHA512 8058f7c6853acf709fdf4e0ce169af4281e2236a615261c0e148965dc1899af78b558ae5231600a106c538c1790ad886bea80ba7ebf278c70b6d553e58c0202b
+DIST pytest_localftpserver-1.1.4.tar.gz 44573 BLAKE2B 8c5bd0065d36d7c312944ce41747db141c90b7cbad134b6d3ce387cc9ef3f536882b27d1d0c23c67fb9e75546e62d0b1434faaa577c61f07a9915bf146b6a9e2 SHA512 67f7ca9d212f187f2e91d274523390438e07c52dc048b832e65012ef49d2843002806db1fbf2eba560bef671a0ef541bfb44f6b8226fe5d9d40acd08d53c4f48
diff --git a/dev-python/pytest-localftpserver/pytest-localftpserver-1.1.4.ebuild b/dev-python/pytest-localftpserver/pytest-localftpserver-1.1.4.ebuild
new file mode 100644
index 000000000000..e826b9bbbf46
--- /dev/null
+++ b/dev-python/pytest-localftpserver/pytest-localftpserver-1.1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A PyTest plugin which provides an FTP fixture for your tests"
+HOMEPAGE="https://pypi.org/project/pytest-localserver/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="dev-python/pyftpdlib[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+EPYTEST_IGNORE=(
+ # These tests require python wget module, but not in Portage
+ tests/test_pytest_localftpserver.py
+ tests/test_pytest_localftpserver_TLS.py
+ tests/test_pytest_localftpserver_with_env_var.py
+)
+
+distutils_enable_tests pytest