summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-20 07:12:24 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-20 07:13:29 +0100
commit1b7c9370350ad93e9cdda2d898807e36d87b112f (patch)
tree052882d72bdca4c44213a04d04783e154e59c019 /dev-python/pytest-lazy-fixtures
parentdev-python/cbor2: Bump to 5.6.2 (diff)
downloadgentoo-1b7c9370350ad93e9cdda2d898807e36d87b112f.tar.gz
gentoo-1b7c9370350ad93e9cdda2d898807e36d87b112f.tar.bz2
gentoo-1b7c9370350ad93e9cdda2d898807e36d87b112f.zip
dev-python/pytest-lazy-fixtures: New package, v1.0.5
New test dependency of dev-python/prettytable, replacement for dev-python/pytest-lazy-fixture, clearly named to maximize confusion. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-lazy-fixtures')
-rw-r--r--dev-python/pytest-lazy-fixtures/Manifest1
-rw-r--r--dev-python/pytest-lazy-fixtures/metadata.xml12
-rw-r--r--dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.5.ebuild34
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pytest-lazy-fixtures/Manifest b/dev-python/pytest-lazy-fixtures/Manifest
new file mode 100644
index 000000000000..d45565e7a43c
--- /dev/null
+++ b/dev-python/pytest-lazy-fixtures/Manifest
@@ -0,0 +1 @@
+DIST pytest-lazy-fixtures-1.0.5.gh.tar.gz 20107 BLAKE2B 543f1a2c9a134fc238c686286b81367c3d6ad21b0bb4b171e2c00f1b961a7813a6c6b141dd265a360c40da7d6e1fd0d48c5ea8d8fc3804a09a39447c0c1c7970 SHA512 c84bce864c5e482c5115ba4c1c8caec9e97a85af4fc839a9fa3a472306d12e1c4564cf4323545be2c6af52c1dc22c24a3e25eae434696953f9efd5d822663601
diff --git a/dev-python/pytest-lazy-fixtures/metadata.xml b/dev-python/pytest-lazy-fixtures/metadata.xml
new file mode 100644
index 000000000000..e66300e8bbd2
--- /dev/null
+++ b/dev-python/pytest-lazy-fixtures/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">dev-petrov/pytest-lazy-fixtures</remote-id>
+ <remote-id type="pypi">pytest-lazy-fixtures</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.5.ebuild b/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.5.ebuild
new file mode 100644
index 000000000000..25fbd2f286ef
--- /dev/null
+++ b/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows you to use fixtures in @pytest.mark.parametrize"
+HOMEPAGE="
+ https://github.com/dev-petrov/pytest-lazy-fixtures/
+ https://pypi.org/project/pytest-lazy-fixtures/
+"
+SRC_URI="
+ https://github.com/dev-petrov/pytest-lazy-fixtures/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pytest-7[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}