summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-28 09:21:10 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-28 10:03:37 +0100
commit09f5e589307034b0d42d8affc02177a4b8fb506b (patch)
tree50d07fbb20ef1a7d9688fe0fe8add80bdb0fb7cf /dev-python/pytest-httpx
parentdev-python/pyFFTW: Bump to 0.13.0 (diff)
downloadgentoo-09f5e589307034b0d42d8affc02177a4b8fb506b.tar.gz
gentoo-09f5e589307034b0d42d8affc02177a4b8fb506b.tar.bz2
gentoo-09f5e589307034b0d42d8affc02177a4b8fb506b.zip
dev-python/pytest-httpx: Bump to 0.17.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.17.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index c2365991ac3d..ec507f012f65 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,3 +1,4 @@
DIST pytest-httpx-0.13.0.tar.gz 21515 BLAKE2B 691ce45dd2b27c8f47724e3356ba96e62a0d6a7ce7d3feea68295a873c12f9a3df00d5b25aad7ef8a1154e887077ae6f6c1b12f3685a0669534a0d0ee8aae68c SHA512 514d9acacdfd60d13b5ce2c5ebe46d0e4d16c1b06fd359b0b9515ae2fa9091296537f369882a78bdfad48e9a0aad0b2f8c172c2e54f4ae9e23ba03220c7c17fb
DIST pytest-httpx-0.17.1.tar.gz 23310 BLAKE2B 3b26a50380916a556657a02bc4d44ceb523261f14404eaf3461dae8adb99e913e820c55942bc200b6d23f85447bf74e37c8cbfea2c934489e5d91a56f47b186a SHA512 8fa9447bf50f9bf46ad781abbf9e5d46609e2796a6ec26d39b15c1cda99fc936af6b540c27f9cbe4f40948f041ceedd074c312815fe5ea6b023da20112c83f69
DIST pytest-httpx-0.17.2.tar.gz 23385 BLAKE2B 17a00a7c733bca7faf8e05914c0744288fe8555bc9d8f94d45ce0162b86417fcf608d339d9d4a24514e2897db879a6d13c41f665a8cf5d3c1ac1769c246a582e SHA512 aaeded94d204d53bf96f802668449361c291d4b0accbe614d8c80d609482f6b10945afb255b81d4199187f3c50cb98d35d5acfd75423283907223ca924b85444
+DIST pytest-httpx-0.17.3.tar.gz 23737 BLAKE2B 1f335542c1d6940d68b023682df6a1fabe93e8e21b70e113830bc4895481fe1cbf074490b176ecd91f595df960790f7e305c3809af3ba5039b96c8748b40ee40 SHA512 b3c2dc8c5015f44a511659b51843cb9cf8ada163ebd7fe4ccb50438d6e191fdc84bb84f38fcd0c27dbfe0592314da0df8d319caecad32f37e3a30de40b496299
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.17.3.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.17.3.ebuild
new file mode 100644
index 000000000000..d3b09a2a7442
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.17.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="https://colin-b.github.io/pytest_httpx/"
+SRC_URI="https://github.com/Colin-b/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.21*[${PYTHON_USEDEP}]
+ =dev-python/pytest-6*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest