summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-08-23 18:06:06 +0200
committerMichał Górny <mgorny@gentoo.org>2015-08-23 18:10:59 +0200
commite4fc17c58c62d72906e91c88eb29d343b4d82cef (patch)
tree2b83c267892b2fa05d010eb93208e2d2ed0f80ce /dev-python/pypy3
parentmedia-gfx/eog-plugins: run python_setup for non-binary pkg_setup (diff)
downloadgentoo-e4fc17c58c62d72906e91c88eb29d343b4d82cef.tar.gz
gentoo-e4fc17c58c62d72906e91c88eb29d343b4d82cef.tar.bz2
gentoo-e4fc17c58c62d72906e91c88eb29d343b4d82cef.zip
dev-python/pypy*: Fix pkg_{pretend,setup} not to run for binpkgs
Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-python/pypy3')
-rw-r--r--dev-python/pypy3/pypy3-2.4.0.ebuild42
1 files changed, 23 insertions, 19 deletions
diff --git a/dev-python/pypy3/pypy3-2.4.0.ebuild b/dev-python/pypy3/pypy3-2.4.0.ebuild
index 9903c1bc0026..85b260bf315e 100644
--- a/dev-python/pypy3/pypy3-2.4.0.ebuild
+++ b/dev-python/pypy3/pypy3-2.4.0.ebuild
@@ -41,32 +41,36 @@ PDEPEND="app-admin/python-updater"
S="${WORKDIR}/${P}-src"
pkg_pretend() {
- if use low-memory; then
- CHECKREQS_MEMORY="1750M"
- use amd64 && CHECKREQS_MEMORY="3500M"
- else
- CHECKREQS_MEMORY="3G"
- use amd64 && CHECKREQS_MEMORY="6G"
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if use low-memory; then
+ CHECKREQS_MEMORY="1750M"
+ use amd64 && CHECKREQS_MEMORY="3500M"
+ else
+ CHECKREQS_MEMORY="3G"
+ use amd64 && CHECKREQS_MEMORY="6G"
+ fi
fi
check-reqs_pkg_pretend
}
pkg_setup() {
- pkg_pretend
-
- # unset to allow forcing pypy below :)
- use low-memory && local EPYTHON=
- if python_is_installed pypy && [[ ! ${EPYTHON} || ${EPYTHON} == pypy ]]; then
- einfo "Using PyPy to perform the translation."
- local EPYTHON=pypy
- else
- einfo "Using ${EPYTHON:-python2} to perform the translation. Please note that upstream"
- einfo "recommends using PyPy for that. If you wish to do so, please install"
- einfo "virtual/pypy and ensure that EPYTHON variable is unset."
- fi
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ pkg_pretend
+
+ # unset to allow forcing pypy below :)
+ use low-memory && local EPYTHON=
+ if python_is_installed pypy && [[ ! ${EPYTHON} || ${EPYTHON} == pypy ]]; then
+ einfo "Using PyPy to perform the translation."
+ local EPYTHON=pypy
+ else
+ einfo "Using ${EPYTHON:-python2} to perform the translation. Please note that upstream"
+ einfo "recommends using PyPy for that. If you wish to do so, please install"
+ einfo "virtual/pypy and ensure that EPYTHON variable is unset."
+ fi
- python-any-r1_pkg_setup
+ python-any-r1_pkg_setup
+ fi
}
src_prepare() {