summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-25 04:28:06 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-25 04:55:32 +0200
commit2a04ab5c6120e222cb0316a0ca20c9ccbeb7bdc4 (patch)
tree74f44e0b2cc38ec3b600d7f483224da22768cd8d /dev-python/pygit2
parentdev-python/pypdf: Bump to 3.16.2 (diff)
downloadgentoo-2a04ab5c6120e222cb0316a0ca20c9ccbeb7bdc4.tar.gz
gentoo-2a04ab5c6120e222cb0316a0ca20c9ccbeb7bdc4.tar.bz2
gentoo-2a04ab5c6120e222cb0316a0ca20c9ccbeb7bdc4.zip
dev-python/pygit2: Bump to 1.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/Manifest1
-rw-r--r--dev-python/pygit2/pygit2-1.13.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index 78a29ff29419..aabf87015649 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1 +1,2 @@
DIST pygit2-1.12.2.tar.gz 738453 BLAKE2B 805472147021296b28f0d47f97e5b42355e2f8eb418cc48134a8c2a0c606e04bdf6ee9ddd5586949652b36d921631aaa16fb739d8491db01196c7ecb26f2ea13 SHA512 adf82f385b0cb8e239113171e7e4d75d4902828b18a04f2624c6931f7d11648ae0503d615ef5d89ddc477b94c5ac48354be223e2bde7d4c111a957e114b6a28d
+DIST pygit2-1.13.1.tar.gz 739041 BLAKE2B 37997247edcc8b4268ea8e0347be4673ccd1e12e0cf1c1be37849560f91335c39998d7c42b0fc9ca40c9b5cbf315154ee13a5e9453d266ebce1a6f6ebb80fed6 SHA512 632d60c1d0602b264504b0e99458c93f0f3699b5ebff34b70ea9381a4472fd938db426c04b6ec0b8b3e5c85aaede440ed28dda232b55954813fce099df6d94e8
diff --git a/dev-python/pygit2/pygit2-1.13.1.ebuild b/dev-python/pygit2/pygit2-1.13.1.ebuild
new file mode 100644
index 000000000000..28fd10216da0
--- /dev/null
+++ b/dev-python/pygit2/pygit2-1.13.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="
+ https://github.com/libgit2/pygit2/
+ https://pypi.org/project/pygit2/
+"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+ =dev-libs/libgit2-1.7*:=
+"
+BDEPEND="
+ >=dev-python/cffi-1.9.1:=[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unconditionally prevent it from using network
+ sed -i -e '/has_network/s:True:False:' test/utils.py || die
+}
+
+src_test() {
+ rm -r pygit2 || die
+ distutils-r1_src_test
+}