summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-12-02 21:23:38 +0200
committerSam James <sam@gentoo.org>2023-12-02 21:29:35 +0000
commit4aaf80f3b84db98e0aa7aa46b42edb9efdba8181 (patch)
tree523825dd3f1cb072e9bb682d27975b0da1b1c1e6 /dev-python/pygdbmi
parentgames-engines/fheroes2: drop 1.0.9 (diff)
downloadgentoo-4aaf80f3b84db98e0aa7aa46b42edb9efdba8181.tar.gz
gentoo-4aaf80f3b84db98e0aa7aa46b42edb9efdba8181.tar.bz2
gentoo-4aaf80f3b84db98e0aa7aa46b42edb9efdba8181.zip
dev-python/pygdbmi: new package, add 0.11.0.0
Closes: https://bugs.gentoo.org/919056 Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/34096 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pygdbmi')
-rw-r--r--dev-python/pygdbmi/Manifest1
-rw-r--r--dev-python/pygdbmi/metadata.xml20
-rw-r--r--dev-python/pygdbmi/pygdbmi-0.11.0.0.ebuild31
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pygdbmi/Manifest b/dev-python/pygdbmi/Manifest
new file mode 100644
index 000000000000..260731862d64
--- /dev/null
+++ b/dev-python/pygdbmi/Manifest
@@ -0,0 +1 @@
+DIST pygdbmi-0.11.0.0.gh.tar.gz 30784 BLAKE2B a3d6bc51640dac78c072ef0162bc1d546707f1b220d8d695595d05a5bcdea8b31b5e23ad916cd2a58bbd4bec2f9fd32b6a9294f00957d890fefd0ecf457ed0de SHA512 11bbc0a9353dbb9d96cb9c71d45a68de446ac6cf1cd110b8f508143218783d2cdfa685874a9b9483933fc58fcfcbb7524a3b670d1c8a6117e8d6484586f1ced6
diff --git a/dev-python/pygdbmi/metadata.xml b/dev-python/pygdbmi/metadata.xml
new file mode 100644
index 000000000000..5b3024573289
--- /dev/null
+++ b/dev-python/pygdbmi/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>parona@protonmail.com</email>
+ <name>Alfred Wingate</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">cs01/pygdbmi</remote-id>
+ <remote-id type="pypi">pygdbmi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pygdbmi/pygdbmi-0.11.0.0.ebuild b/dev-python/pygdbmi/pygdbmi-0.11.0.0.ebuild
new file mode 100644
index 000000000000..79298b8f96fd
--- /dev/null
+++ b/dev-python/pygdbmi/pygdbmi-0.11.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to parse gdb mi output and interact with gdb subprocesses"
+HOMEPAGE="
+ https://cs01.github.io/pygdbmi/
+ https://github.com/cs01/pygdbmi/
+ https://pypi.org/project/pygdbmi/
+"
+# no tests in sdist
+SRC_URI="
+ https://github.com/cs01/pygdbmi/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=sys-devel/gdb-9.6
+"
+
+distutils_enable_tests pytest