summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-17 04:24:15 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-17 04:24:15 +0200
commit480b822fc98ab260c51d7ae19d28eb7c740be1d7 (patch)
tree9ef2d77cbe78501ddbc8364bfe5b14828c48db76 /dev-python/puremagic
parentdev-python/apsw: Bump to 3.46.0.1 (diff)
downloadgentoo-480b822fc98ab260c51d7ae19d28eb7c740be1d7.tar.gz
gentoo-480b822fc98ab260c51d7ae19d28eb7c740be1d7.tar.bz2
gentoo-480b822fc98ab260c51d7ae19d28eb7c740be1d7.zip
dev-python/puremagic: Bump to 1.24
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/puremagic')
-rw-r--r--dev-python/puremagic/Manifest1
-rw-r--r--dev-python/puremagic/puremagic-1.24.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/puremagic/Manifest b/dev-python/puremagic/Manifest
index 34caed6c7e4b..27f1458beae6 100644
--- a/dev-python/puremagic/Manifest
+++ b/dev-python/puremagic/Manifest
@@ -1 +1,2 @@
DIST puremagic-1.23.gh.tar.gz 306804 BLAKE2B b9da78fc20ee77dac85065f85a8770273ece5f97c372c42e274d272c3c389cca2ed1433774f96d1b55dff01ff542c63ad5093befa5c3530b052de32ffa142a77 SHA512 9bdb6ae0158ecf5d87e82de112ce9d988ac2b4a29d06dd06cba9c4675fe11d270c7cab611f8cb8ffb5ccd622be66fe43b441f203d27e9c4c9feb55bb81036fce
+DIST puremagic-1.24.gh.tar.gz 309763 BLAKE2B 7d2920d2028bb8db9f87f569ae57a00436289e2e6661a07da39d2cdf96975d56c5fbe6569a2909127fef1a1e8c51514ae5f1730df85e620a8cd84abfa8d0dd03 SHA512 06ef1008788c2941df9b3237d41df9908bf172e22f66e478470ab66d3cefd0c8d598f8a95df285bfde58477a98d4da557c0fef7a691b30bcf3d82d76067c518d
diff --git a/dev-python/puremagic/puremagic-1.24.ebuild b/dev-python/puremagic/puremagic-1.24.ebuild
new file mode 100644
index 000000000000..7a5fd34c2d27
--- /dev/null
+++ b/dev-python/puremagic/puremagic-1.24.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python implementation of magic file detection"
+HOMEPAGE="
+ https://github.com/cdgriffith/puremagic/
+ https://pypi.org/project/puremagic/
+"
+SRC_URI="
+ https://github.com/cdgriffith/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( CHANGELOG.md README.rst )
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}