summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-28 03:29:44 +0000
committerSam James <sam@gentoo.org>2023-12-28 03:29:44 +0000
commit740a0cab7dbea74f2f24d248428a457883226777 (patch)
tree60b8e418475dfd496700ab0aba8233d8c5323869 /dev-python/pkgcraft
parentdev-python/pyupgrade: drop 3.12.0, 3.13.0, 3.14.0 (diff)
downloadgentoo-740a0cab7dbea74f2f24d248428a457883226777.tar.gz
gentoo-740a0cab7dbea74f2f24d248428a457883226777.tar.bz2
gentoo-740a0cab7dbea74f2f24d248428a457883226777.zip
dev-python/pkgcraft: drop 0.0.6, 0.0.7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pkgcraft')
-rw-r--r--dev-python/pkgcraft/Manifest2
-rw-r--r--dev-python/pkgcraft/pkgcraft-0.0.6.ebuild81
-rw-r--r--dev-python/pkgcraft/pkgcraft-0.0.7.ebuild81
3 files changed, 0 insertions, 164 deletions
diff --git a/dev-python/pkgcraft/Manifest b/dev-python/pkgcraft/Manifest
index ad4355f0118c..be76ce9fbe39 100644
--- a/dev-python/pkgcraft/Manifest
+++ b/dev-python/pkgcraft/Manifest
@@ -1,3 +1 @@
-DIST pkgcraft-0.0.6.tar.gz 406538 BLAKE2B 5c90b57cb11e9f754cd695989994b3a9be52007482981c997f2e361fbbb72aeb0810d7f41dea1cdcd74c47840bb1c3b2cf225c967ba76b01769da93f909d9911 SHA512 ddd7bf77a3509156e8c16e5aeeb94a5f4530d9d1a3e6617d3974adfae7b46f0b0d31f4828dbd70261b42c883e776bf7572ca2fe8e23c9216637d886b9d8811cc
-DIST pkgcraft-0.0.7.tar.gz 406608 BLAKE2B 733876723c676ac0000699440955518bb8a2fb35cc5bb1664e791c2be172a8a4ce90faff849eeacf293e4071dee0bb6b5ae18a5dba0c04ee79b52c1153c5b8d1 SHA512 e01cce2e5840a84ab43b6f9e9c0c15caa0d5247ff85e7bac4452411cccc87eea88193e12585bfebd01b73aa27f4c1d1f0e72982f61270f894890be9b38961e3e
DIST pkgcraft-0.0.8.tar.gz 416513 BLAKE2B 8bf16807990344777981f21efe91fc57503f56a0f55c9be3eef9d407d09e9f3601318b7191968fa379fd31f4c9b0bee37e6af68ae792d9398735cf0298165495 SHA512 bfa049ecb003574bcb77fc7f76b58cb2ded8163888bd08ac982fefb8ec4f8cccb51a16f1e1cbffdc0da83965927fdc918983bc8b48b99b3cd43bb697aa6107dd
diff --git a/dev-python/pkgcraft/pkgcraft-0.0.6.ebuild b/dev-python/pkgcraft/pkgcraft-0.0.6.ebuild
deleted file mode 100644
index 204a8185dbfb..000000000000
--- a/dev-python/pkgcraft/pkgcraft-0.0.6.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for pkgcraft"
-HOMEPAGE="
- https://pypi.org/project/pkgcraft/
- https://github.com/pkgcraft/pkgcraft-python/
-"
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/pkgcraft/pkgcraft-python.git"
- inherit git-r3
-
- PKGCRAFT_VERSION_MAX="99999" # extra 9 here or 9999 isn't mergable per DEPEND below
- PKGCRAFT_VERSION_MIN="9999"
-else
- SRC_URI="https://github.com/pkgcraft/pkgcraft-python/releases/download/v${PV}/${P/-python}.tar.gz"
- S="${WORKDIR}"/${P/-python}
-
- KEYWORDS="~amd64 ~arm64"
-
- PKGCRAFT_VERSION_MAX="9999"
- PKGCRAFT_VERSION_MIN="0.0.11"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+examples"
-
-DEPEND="
- <sys-libs/pkgcraft-${PKGCRAFT_VERSION_MAX}
- >=sys-libs/pkgcraft-${PKGCRAFT_VERSION_MIN}:=
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- >=dev-python/cython-3[${PYTHON_USEDEP}]
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- virtual/pkgconfig
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- if [[ ${PV} != 9999 ]] ; then
- local actual_pkgcraft_min=$(sed -En '/^MIN_VERSION =/{s/[^0-9.]//gp}' setup.py || die)
- if [[ ${actual_pkgcraft_min} != ${PKGCRAFT_VERSION_MIN} ]] ; then
- eerror "Expected minimum pkgcraft-c version: ${PKGCRAFT_VERSION_MIN}"
- eerror "Actual minimum pkgcraft-c version: ${actual_pkgcraft_min}"
- die "Mismatch between setup.py's MIN_VERSION and ebuild!"
- fi
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-python_install() {
- # Conditional because these aren't installed officially right now
- # and the naming is just for convenience.
- if use examples ; then
- while IFS= read -r -d '' file ; do
- python_newexe "${S}"/examples/${file##*/} pkgcraft-${file##*/}
- done < <(find "${S}"/examples -type f -executable -print0 || die)
- fi
-
- distutils-r1_python_install
-}
diff --git a/dev-python/pkgcraft/pkgcraft-0.0.7.ebuild b/dev-python/pkgcraft/pkgcraft-0.0.7.ebuild
deleted file mode 100644
index c5c9bca81ac1..000000000000
--- a/dev-python/pkgcraft/pkgcraft-0.0.7.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for pkgcraft"
-HOMEPAGE="
- https://pypi.org/project/pkgcraft/
- https://github.com/pkgcraft/pkgcraft-python/
-"
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/pkgcraft/pkgcraft-python.git"
- inherit git-r3
-
- PKGCRAFT_VERSION_MAX="99999" # extra 9 here or 9999 isn't mergable per DEPEND below
- PKGCRAFT_VERSION_MIN="9999"
-else
- SRC_URI="https://github.com/pkgcraft/pkgcraft-python/releases/download/v${PV}/${P/-python}.tar.gz"
- S="${WORKDIR}"/${P/-python}
-
- KEYWORDS="~amd64 ~arm64"
-
- PKGCRAFT_VERSION_MAX="9999"
- PKGCRAFT_VERSION_MIN="0.0.12"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+examples"
-
-DEPEND="
- <sys-libs/pkgcraft-${PKGCRAFT_VERSION_MAX}
- >=sys-libs/pkgcraft-${PKGCRAFT_VERSION_MIN}:=
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- >=dev-python/cython-3[${PYTHON_USEDEP}]
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- virtual/pkgconfig
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- if [[ ${PV} != 9999 ]] ; then
- local actual_pkgcraft_min=$(sed -En '/^MIN_VERSION =/{s/[^0-9.]//gp}' setup.py || die)
- if [[ ${actual_pkgcraft_min} != ${PKGCRAFT_VERSION_MIN} ]] ; then
- eerror "Expected minimum pkgcraft-c version: ${PKGCRAFT_VERSION_MIN}"
- eerror "Actual minimum pkgcraft-c version: ${actual_pkgcraft_min}"
- die "Mismatch between setup.py's MIN_VERSION and ebuild!"
- fi
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-python_install() {
- # Conditional because these aren't installed officially right now
- # and the naming is just for convenience.
- if use examples ; then
- while IFS= read -r -d '' file ; do
- python_newexe "${S}"/examples/${file##*/} pkgcraft-${file##*/}
- done < <(find "${S}"/examples -type f -executable -print0 || die)
- fi
-
- distutils-r1_python_install
-}