summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-31 06:49:17 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-31 07:52:36 +0200
commitc9a6cd3b49015fed4d20305625f88970347292cb (patch)
tree3ccccaf49d9aad32333eb79d43035088127d484b /dev-python/phonenumbers
parentdev-python/fakeredis: Bump to 2.23.4 (diff)
downloadgentoo-c9a6cd3b49015fed4d20305625f88970347292cb.tar.gz
gentoo-c9a6cd3b49015fed4d20305625f88970347292cb.tar.bz2
gentoo-c9a6cd3b49015fed4d20305625f88970347292cb.zip
dev-python/phonenumbers: Bump to 8.13.42
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/phonenumbers')
-rw-r--r--dev-python/phonenumbers/Manifest1
-rw-r--r--dev-python/phonenumbers/phonenumbers-8.13.42.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/phonenumbers/Manifest b/dev-python/phonenumbers/Manifest
index a3431089b851..d5586bc77728 100644
--- a/dev-python/phonenumbers/Manifest
+++ b/dev-python/phonenumbers/Manifest
@@ -1 +1,2 @@
DIST python-phonenumbers-8.13.40.gh.tar.gz 4914854 BLAKE2B eab8e8e28a5895f9eb92ce9198a77a4d9bfd6f3d58f17c5a7909913ea43af2efd1dcff84c9d517c5f4f17ba87ce68786ab64f523b10ddf6aa3354801021843d3 SHA512 ef2199d86998201485d48cf4d5d56baa82476dbe41b2b4f89aebfcbf840af0ae35a78308a0f74b2daad58a2c330e10444c93ffb59a402d5fe5cc5baff78fdcb2
+DIST python-phonenumbers-8.13.42.gh.tar.gz 4915152 BLAKE2B 4abdd4e583e09f7915203f8b9a7908eeae7c57910b21e3fd2d8bccef4ba799ddb13299ff0a9fa307665c08955923f3f56a56893b5fa1ec0ccb102feda286aeed SHA512 21cb0093486d3f29f1ed7b9ce9a0caa06df854ef2f4120c345f07ad7a73e374bf94e8f7844e29f71157f5b645423385ae39d3ec6a0ea6bd35a77881e76b9afb9
diff --git a/dev-python/phonenumbers/phonenumbers-8.13.42.ebuild b/dev-python/phonenumbers/phonenumbers-8.13.42.ebuild
new file mode 100644
index 000000000000..2fc9bdbaa7c9
--- /dev/null
+++ b/dev-python/phonenumbers/phonenumbers-8.13.42.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Python port of Google's libphonenumber"
+HOMEPAGE="
+ https://github.com/daviddrysdale/python-phonenumbers/
+ https://pypi.org/project/phonenumbers/
+"
+SRC_URI="
+ https://github.com/daviddrysdale/python-phonenumbers/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}/python
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( ../README.md )
+
+python_test() {
+ "${EPYTHON}" testwrapper.py -v || die "Tests failed with ${EPYTHON}"
+}