summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-28 07:03:59 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-28 07:25:27 +0200
commitc00f1b8bdfd174573ca5fe4e8859d8720d6f20dd (patch)
tree1aac191fd9808b88de370c7731350b6b56c7e971 /dev-python/path
parentdev-python/path: Bump to 16.16.0 (diff)
downloadgentoo-c00f1b8bdfd174573ca5fe4e8859d8720d6f20dd.tar.gz
gentoo-c00f1b8bdfd174573ca5fe4e8859d8720d6f20dd.tar.bz2
gentoo-c00f1b8bdfd174573ca5fe4e8859d8720d6f20dd.zip
dev-python/path: Bump to 17.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/path')
-rw-r--r--dev-python/path/Manifest1
-rw-r--r--dev-python/path/path-17.0.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/path/Manifest b/dev-python/path/Manifest
index baf3d09a7c55..4b7fad2f908e 100644
--- a/dev-python/path/Manifest
+++ b/dev-python/path/Manifest
@@ -1,3 +1,4 @@
DIST path-16.14.0.tar.gz 50076 BLAKE2B 0046501fc05e65a211360e84cd30e312c6b1a18d482a36b8451d338cd8c87749254fc31dbe497ec55d55880dab0eae3b88ce412b2058454c0c1ad01cb180d522 SHA512 1b35bf06413d3f5da5fd818b2327458ef92a3bcb7e0d8108e4db113e3819f3723384650f7f9e889862bfcd2bc761f2be46932d11023f5a1dcda6bb4c51074ec0
DIST path-16.15.0.tar.gz 50599 BLAKE2B 5b87e10e0d8d4da4b5e56e36009d8cbe50b0a3465d8b511f26754fbf6a207fd0724b70d1f8c691596919bac7eae9696484da5b9733e1ebfaf24a82f18f9295dc SHA512 e325ab564257d2088dd9c9313d518f67a0ffbf6154d3adfdf0adc450aa5f6b8c1e9195d155576ab841426ec3cd03659133f5b71411d949721f65ffd9441ff2fd
DIST path-16.16.0.tar.gz 50905 BLAKE2B 0cb441dfc02b104235a6073e0b392dc2ccac8c4cf9cb16be9a3af2386ecc109ce81bae8960fce9b506372b86e6336a36cec17c5bb917aecce28c56fda0729f27 SHA512 cdc65ebe468ea21bda98418da8b2791fb976f4810545a1dfd44aa9278c74e0829560b852e9a5236ddc1cf38b59416789250d1623d7340bbc377b002504df0f0f
+DIST path-17.0.0.tar.gz 49721 BLAKE2B eb25e41c5fd5a269023dbdf331a1abb4228707f8b2ca8e4523fabd749fe7c76dc564ea18dd1d9ee4af085bfe72a47400c2bd21c8235af8654998bbefbeb87512 SHA512 9e2e6d51f32f6380d944006fc618d41fb6136d878b758a10a81b3cee5b3e11e5330fba3cc88b0f185c4244aa38f338a32f49685da733539e2cf1cd281ed65412
diff --git a/dev-python/path/path-17.0.0.ebuild b/dev-python/path/path-17.0.0.ebuild
new file mode 100644
index 000000000000..8534249f6b73
--- /dev/null
+++ b/dev-python/path/path-17.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="
+ https://github.com/jaraco/path/
+ https://pypi.org/project/path/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+)