summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-11 08:49:26 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-11 09:53:12 +0200
commit030dade93e0b69ca6b5620391728f297218549ad (patch)
tree5ec3dc49519199e6258cdc86a47c6cee830969a6 /dev-python/path-py/path-py-8.1.1.ebuild
parentdev-python/mako: Version Bump (diff)
downloadgentoo-030dade93e0b69ca6b5620391728f297218549ad.tar.gz
gentoo-030dade93e0b69ca6b5620391728f297218549ad.tar.bz2
gentoo-030dade93e0b69ca6b5620391728f297218549ad.zip
dev-python/path-py: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/path-py/path-py-8.1.1.ebuild')
-rw-r--r--dev-python/path-py/path-py-8.1.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/path-py/path-py-8.1.1.ebuild b/dev-python/path-py/path-py-8.1.1.ebuild
new file mode 100644
index 000000000000..b490b2b7e6e1
--- /dev/null
+++ b/dev-python/path-py/path-py-8.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_P="path.py-${PV}"
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="http://pythonhosted.org/path.py https://pypi.python.org/pypi/path.py https://github.com/jaraco/path.py"
+SRC_URI="mirror://pypi/p/path.py/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed '/setuptools_scm/d' -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}