summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-06-17 13:08:26 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-06-17 13:08:26 +0200
commit712e2d80b9b2043efe19537a0a6fd2f24131dee4 (patch)
tree8501a22ca846a014185f75f9f28463d663ae125a /dev-python/ntlm-auth
parentwww-plugins/pdfjs: 2.4.456 bump (diff)
downloadgentoo-712e2d80b9b2043efe19537a0a6fd2f24131dee4.tar.gz
gentoo-712e2d80b9b2043efe19537a0a6fd2f24131dee4.tar.bz2
gentoo-712e2d80b9b2043efe19537a0a6fd2f24131dee4.zip
dev-python/ntlm-auth: 1.5.0 bump
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'dev-python/ntlm-auth')
-rw-r--r--dev-python/ntlm-auth/Manifest1
-rw-r--r--dev-python/ntlm-auth/ntlm-auth-1.5.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/ntlm-auth/Manifest b/dev-python/ntlm-auth/Manifest
index 26464b4ff5e8..d718b298477f 100644
--- a/dev-python/ntlm-auth/Manifest
+++ b/dev-python/ntlm-auth/Manifest
@@ -1 +1,2 @@
DIST ntlm-auth-1.4.0.tar.gz 40745 BLAKE2B bf2c0dab7303cb0f87d83ed11d79bc12b8f74095f2f251c190eb43879bc0e9419dedf706fcb4929c51138658910bdfa836778084b34c974ca120aeb848e2da0e SHA512 abe0260c66e2b5f57c1fd672ea121129926f1c32020166dd61973cf51f6bd320f6057f3a148d602b96d8417c2ad57c335048da185100417401e049ff14b46004
+DIST ntlm-auth-1.5.0.tar.gz 41826 BLAKE2B fb313cdb4f1022e0cbc1ffcb048a587baca400a75e053ea8943d960f21746e847080db20169f55e6a3060a8b8502637ce7dc269b66bdaffe98c3f769b2b22358 SHA512 cf08b23e49d45c528404b70b6be88f6c3edee9fd0d4584f3962931a08a0982cdad4089963a95aea911b6eb4db32a932536cf6d9c02c292cd447e0a9c6b3b802b
diff --git a/dev-python/ntlm-auth/ntlm-auth-1.5.0.ebuild b/dev-python/ntlm-auth/ntlm-auth-1.5.0.ebuild
new file mode 100644
index 000000000000..0c194f2bc5c1
--- /dev/null
+++ b/dev-python/ntlm-auth/ntlm-auth-1.5.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Calculates NTLM Authentication codes"
+HOMEPAGE="https://github.com/jborean93/ntlm-auth"
+SRC_URI="https://github.com/jborean93/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"