summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-03 21:01:22 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-03 21:01:22 +0100
commit207b999de645f07db3e2b39d8c0d9c509f3b5677 (patch)
tree67a9243b1d325d92304ea765cd20ccbaddab62c8 /dev-python/mpi4py
parentdev-python/xarray: Remove old (diff)
downloadgentoo-207b999de645f07db3e2b39d8c0d9c509f3b5677.tar.gz
gentoo-207b999de645f07db3e2b39d8c0d9c509f3b5677.tar.bz2
gentoo-207b999de645f07db3e2b39d8c0d9c509f3b5677.zip
dev-python/mpi4py: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mpi4py')
-rw-r--r--dev-python/mpi4py/Manifest1
-rw-r--r--dev-python/mpi4py/mpi4py-3.1.4.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/mpi4py/Manifest b/dev-python/mpi4py/Manifest
index 94297609a46f..19f3f4338db2 100644
--- a/dev-python/mpi4py/Manifest
+++ b/dev-python/mpi4py/Manifest
@@ -1,2 +1 @@
-DIST mpi4py-3.1.4.tar.gz 2493282 BLAKE2B e1a048e6053263f6685c549e2e6f96072b7d95db68595c8848d0ecdb0a6cadf2b102e4c4ce589053ed17a090335afc56f4b3630b60944aeac7e4bc4ad82d4a1b SHA512 f59ad765bc272f8b63f74cfde4e588f640c4fc3d47d05729509da45a2155f830c1d409ec716ff374756748fa8ebfa6e72f9fbe188a6b89ea3fa115740a532b08
DIST mpi4py-3.1.5.tar.gz 2469777 BLAKE2B 0638e3def52f731b64e2999f83f2d6ccc94dc2f8b37d964c10e49ca12470d3d3ef77ff2737294d85614b2d59d1eec49880e74f2ba3d73fd090152b63c8cc701e SHA512 04da1d6daf66cc86fa3ec574eea6e01749f895035e3394afbc68d6245394c5b03557ede0bda3642b06d9c6ff2c1e6e878a6c8c30d3fa3491392e2e13b82cdec8
diff --git a/dev-python/mpi4py/mpi4py-3.1.4.ebuild b/dev-python/mpi4py/mpi4py-3.1.4.ebuild
deleted file mode 100644
index fc59015a3c47..000000000000
--- a/dev-python/mpi4py/mpi4py-3.1.4.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1 pypi
-
-DESCRIPTION="Message Passing Interface for Python"
-HOMEPAGE="https://github.com/mpi4py/mpi4py https://pypi.org/project/mpi4py/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- virtual/mpi
-"
-DEPEND="${RDEPEND}
- test? (
- virtual/mpi[romio]
- )
-"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- # not needed on install
- rm -vr docs/source || die
- rm test/test_pickle.py || die # disabled by Gentoo-bug #659348
- distutils-r1_python_prepare_all
-}
-
-src_compile() {
- export FAKEROOTKEY=1
- distutils-r1_src_compile
-}
-
-python_test() {
- echo "Beginning test phase"
- pushd "${BUILD_DIR}"/../ &> /dev/null || die
- # spawn is not stable in OpenMPI 4
- # https://github.com/jsquyres/ompi/pull/4#issuecomment-806897758
- # oob_tcp_if_include lo is needed to allow test in systemd-nspawn container
- mpiexec --use-hwthread-cpus --mca btl tcp,self --mca oob_tcp_if_include lo \
- -n 1 "${PYTHON}" -B ./test/runtests.py -v \
- --exclude="test_msgspec" --exclude="test_spawn" ||
- die "Testsuite failed under ${EPYTHON}"
- popd &> /dev/null || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/. )
- use examples && local DOCS=( demo )
- distutils-r1_python_install_all
-}