summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-22 20:33:18 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-22 22:00:50 +0200
commit3e61f0ddd156d4e9503bb28b5a96e8581cc255d2 (patch)
treed646a7186dca2329ea8e8c3cd11ea3b0ed93d2bc /dev-python/moto
parentdev-python/phonenumbers: Bump to 8.13.19 (diff)
downloadgentoo-3e61f0ddd156d4e9503bb28b5a96e8581cc255d2.tar.gz
gentoo-3e61f0ddd156d4e9503bb28b5a96e8581cc255d2.tar.bz2
gentoo-3e61f0ddd156d4e9503bb28b5a96e8581cc255d2.zip
dev-python/moto: Bump to 4.1.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-4.1.15.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index a52f1de6e355..088a958c5d22 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -3,6 +3,7 @@ DIST moto-4.1.11.tar.gz 3565932 BLAKE2B b1bc982ea54d8e2e8f418be8808c23094d263b2d
DIST moto-4.1.12.tar.gz 3589463 BLAKE2B 4672cd3f04173557eb163436e8d3e53abbe4b04516f948119f28cf9c6eda767be9629d2485324648b3124ea6bf421cdcc99835ecb1cda1ab072da29f7c330a50 SHA512 62742fe4b68dbfc134b61573f4cdf8e10f3e5b35f981463a3a2e827caba67482a897472be0e17b724c8a48479477292b60f6328420512bd7687ce7ddea8d7f46
DIST moto-4.1.13.tar.gz 3603599 BLAKE2B aed5e867ccb67c208a6e3f0345c7c00f1cf86d2a31d74eb531aaf5c9cda4d0aa19e99e7b969d2c61935d13efba93267c8fd0e6f2a6d7fd45a7144e346638b781 SHA512 9dc9311b15f4bc7168eb8775667be0660fd78497f9950c7bb37db9eae0fd2956c9bbc0c3d02bc5b76de83b27f2ec67b22e22698c8572f4e01a8da3b261d9d156
DIST moto-4.1.14.tar.gz 3612859 BLAKE2B 35e913bf0745600ea42ba66b5a9cdbdb489a537b066a7c92619c490d4ff057b13f5e72cdeb4425b155174b856584c5fa8ef2d382dde2052316d1b8bb8e033d3e SHA512 6bd963f8aa82aee2166a5deff61e37ffc915b4c14ffd218256ef465b0469f2066eaf70c40df8be40c91a6fc07bec02389ecef26d61de4d503c5e2b630f8ffd38
+DIST moto-4.1.15.tar.gz 3627847 BLAKE2B 65349e72dc6cc90f0ed148a1a68efae0b3c171adbc79d41dee8d058c62f2944a3e55c86c2e8e302ff865208393be551a4b6bf387a33136dfa808443ccfe3869a SHA512 b49541ac8ddd8d669af06253451ddd2e0d70eea63fd2b2fd28eb783b2fb9dccb1e13e650bfca3a5b0f94932b22b112d15317599bc70307828fb2c47191f94da7
DIST moto-4.1.6.tar.gz 3470215 BLAKE2B 78f9c54128ba71fc5e3ba622be0596490bc82df0a17fa80d9f11bf135bdc91d9698cc29445b5765e6057e80f221c016ca8999186201b83b5f929f5831c417f60 SHA512 fb2dc73a66326216a4c5338660dab844de9a46e6626e0ef68bccb3573a3eba693b30b89961b019a4b7a51207ab11335e73cbdf523c75d91a5a9625a1bc409e61
DIST moto-4.1.7.tar.gz 3506753 BLAKE2B 76e38629f1a772816bfa647b90e89e3c4533cd36fa5a8a26e026229dd1dd8bf1cea404f99c85784a6eefa9173aecff7b88ba1ca7b3f890407c2ad7ef29106fac SHA512 3b20d2a535654cee22c909e19eb492e3b4b8fd382d26367c12cee00128dc4d1ea5228ccc97d40a01c5c2707ff3ca1039644268c47c525c79a9b68fc7ee78541c
DIST moto-4.1.8.tar.gz 3520127 BLAKE2B 623d97dbec357227ea401ac98f694eaaa129fcb47f6b160a22bf95f8d52facf9bb3917e00409990a7e447e70de5a94df9f234c3ed615081573169f3976169f3d SHA512 9c3e9825d1e8d09e278f8bbeb11719c4bee756f9e95b2edbe82b4ffbd3acb93008f6ffdc582eb46619104d0b839428b5e8078ef0e341a3b73f0bc61a7ebf806f
diff --git a/dev-python/moto/moto-4.1.15.ebuild b/dev-python/moto/moto-4.1.15.ebuild
new file mode 100644
index 000000000000..03ffd378c1bc
--- /dev/null
+++ b/dev-python/moto/moto-4.1.15.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="
+ https://github.com/getmoto/moto/
+ https://pypi.org/project/moto/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-0.93[${PYTHON_USEDEP}]
+ >=dev-python/cfn-lint-0.40.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.7[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.2.8[${PYTHON_USEDEP}]
+ dev-python/pyaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ # broken code (local variable used referenced before definition)
+ tests/test_appsync/test_appsync_schema.py
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_batch/test_batch_jobs.py::test_cancel_pending_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_failed_dependencies
+ tests/test_batch/test_batch_jobs.py::test_failed_job
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_core/test_docker.py::test_docker_is_running_and_available
+ tests/test_events/test_events_lambdatriggers_integration.py::test_creating_bucket__invokes_lambda
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events0-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events1-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events3-ObjectCreated:Put]"
+ # TODO
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_queue
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_fifo_queue
+ # require py_partiql_parser
+ tests/test_s3/test_s3_select.py
+ tests/test_dynamodb/test_dynamodb_statements.py
+ # broken by new urllib3
+ tests/test_moto_api/recorder/test_recorder.py::TestRecorder::test_s3_upload_data
+ tests/test_moto_api/recorder/test_recorder.py::TestRecorder::test_s3_upload_file_using_requests
+ tests/test_s3/test_s3.py::test_upload_from_file_to_presigned_url
+ tests/test_s3/test_s3.py::test_put_chunked_with_v4_signature_in_body
+ tests/test_s3/test_s3.py::test_presigned_put_url_with_approved_headers
+ tests/test_s3/test_s3.py::test_presigned_put_url_with_custom_headers
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x TZ=UTC
+ # note: pytest-xdist causes random test failures
+ epytest -m 'not network'
+}