summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-01 11:45:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-02 01:19:37 +0200
commitc956035180c107d600413210079654c3c4192712 (patch)
tree2946a4c9d22112739156b0fed57507a9b4014185 /dev-python/matplotlib
parentdev-python/pyperclip: Drop 1.5.27 (diff)
downloadgentoo-c956035180c107d600413210079654c3c4192712.tar.gz
gentoo-c956035180c107d600413210079654c3c4192712.tar.bz2
gentoo-c956035180c107d600413210079654c3c4192712.zip
dev-python/matplotlib: Drop IUSE="qt5"
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/matplotlib-2.2.2-r1.ebuild10
-rw-r--r--dev-python/matplotlib/matplotlib-2.2.4.ebuild10
2 files changed, 10 insertions, 10 deletions
diff --git a/dev-python/matplotlib/matplotlib-2.2.2-r1.ebuild b/dev-python/matplotlib/matplotlib-2.2.2-r1.ebuild
index 9503034ec4c0..6732f35082ae 100644
--- a/dev-python/matplotlib/matplotlib-2.2.2-r1.ebuild
+++ b/dev-python/matplotlib/matplotlib-2.2.2-r1.ebuild
@@ -19,7 +19,7 @@ SLOT="0"
# Fonts: BitstreamVera, OFL-1.1
LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 x86"
-IUSE="cairo doc excel examples gtk3 latex qt5 test tk wxwidgets"
+IUSE="cairo doc excel examples gtk3 latex test tk wxwidgets"
RESTRICT="!test? ( test )"
PY2_FLAGS="|| ( $(python_gen_useflags python2_7) )"
@@ -27,7 +27,7 @@ REQUIRED_USE="
doc? ( ${PY2_FLAGS} )
excel? ( ${PY2_FLAGS} )
wxwidgets? ( ${PY2_FLAGS} )
- test? ( cairo gtk3 latex qt5 tk wxwidgets )"
+ test? ( cairo gtk3 latex tk wxwidgets )"
# #456704 -- a lot of py2-only deps
PY2_USEDEP=$(python_gen_usedep python2_7)
@@ -94,8 +94,7 @@ RDEPEND="${COMMON_DEPEND}
dev-texlive/texlive-fontsrecommended
dev-texlive/texlive-latexextra
dev-texlive/texlive-xetex
- )
- qt5? ( dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}] )"
+ )"
# A few C++ source files are written to srcdir.
# Other than that, the ebuild shall be fit for out-of-source build.
@@ -172,9 +171,10 @@ python_configure() {
pysideagg = False
qt4 = False
qt4agg = False
+ qt5 = False
+ qt5agg = False
$(use_setup cairo)
$(use_setup gtk3)
- $(use_setup qt5)
$(use_setup tk)
EOF
diff --git a/dev-python/matplotlib/matplotlib-2.2.4.ebuild b/dev-python/matplotlib/matplotlib-2.2.4.ebuild
index 824ae05fff3f..d7c77f8d78fb 100644
--- a/dev-python/matplotlib/matplotlib-2.2.4.ebuild
+++ b/dev-python/matplotlib/matplotlib-2.2.4.ebuild
@@ -19,13 +19,13 @@ SLOT="0"
# Fonts: BitstreamVera, OFL-1.1
LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
-IUSE="cairo doc excel examples gtk3 latex qt5 test tk wxwidgets"
+IUSE="cairo doc excel examples gtk3 latex test tk wxwidgets"
RESTRICT="!test? ( test )"
PY2_FLAGS="|| ( $(python_gen_useflags python2_7) )"
REQUIRED_USE="
wxwidgets? ( ${PY2_FLAGS} )
- test? ( cairo gtk3 latex qt5 tk wxwidgets )"
+ test? ( cairo gtk3 latex tk wxwidgets )"
# #456704 -- a lot of py2-only deps
PY2_USEDEP=$(python_gen_usedep python2_7)
@@ -93,8 +93,7 @@ RDEPEND="${COMMON_DEPEND}
dev-texlive/texlive-fontsrecommended
dev-texlive/texlive-latexextra
dev-texlive/texlive-xetex
- )
- qt5? ( dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}] )"
+ )"
# A few C++ source files are written to srcdir.
# Other than that, the ebuild shall be fit for out-of-source build.
@@ -174,9 +173,10 @@ python_configure() {
pysideagg = False
qt4 = False
qt4agg = False
+ qt5 = False
+ qt5agg = False
$(use_setup cairo)
$(use_setup gtk3)
- $(use_setup qt5)
$(use_setup tk)
EOF