summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-02-16 14:29:33 +0200
committerSam James <sam@gentoo.org>2023-02-18 07:15:57 +0000
commit7fb156da546b56d4b4a9195f3316aff6e039909d (patch)
tree314f89735fdcd7601c7f8fdc18ce6a68b8075256 /dev-python/mapbox-vector-tile
parentdev-python/elastic-transport: new package, add 8.4.0 (diff)
downloadgentoo-7fb156da546b56d4b4a9195f3316aff6e039909d.tar.gz
gentoo-7fb156da546b56d4b4a9195f3316aff6e039909d.tar.bz2
gentoo-7fb156da546b56d4b4a9195f3316aff6e039909d.zip
dev-python/mapbox-vector-tile: new package, add 2.0.1
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/mapbox-vector-tile')
-rw-r--r--dev-python/mapbox-vector-tile/Manifest1
-rw-r--r--dev-python/mapbox-vector-tile/mapbox-vector-tile-2.0.1.ebuild35
-rw-r--r--dev-python/mapbox-vector-tile/metadata.xml16
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/mapbox-vector-tile/Manifest b/dev-python/mapbox-vector-tile/Manifest
new file mode 100644
index 000000000000..03b05a5c321d
--- /dev/null
+++ b/dev-python/mapbox-vector-tile/Manifest
@@ -0,0 +1 @@
+DIST mapbox-vector-tile-2.0.1.gh.tar.gz 229202 BLAKE2B 9afa12583f1f2697c8fd3a7ad540851c2b3ea7bca26bf7945aa52ad9c2486f4b6ec0a0bc84e750e18ecb55a51558659284d52efedcb724ec5de98f965d78b954 SHA512 67648c27792557a5e011732c31f8a0a3e6efca8630086e55e6fdc433953b820ef6405031d10692999026c604f3977eb00bafa9a1a7015f02c3dca87ca91eadf6
diff --git a/dev-python/mapbox-vector-tile/mapbox-vector-tile-2.0.1.ebuild b/dev-python/mapbox-vector-tile/mapbox-vector-tile-2.0.1.ebuild
new file mode 100644
index 000000000000..09c1d2ed9048
--- /dev/null
+++ b/dev-python/mapbox-vector-tile/mapbox-vector-tile-2.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Mapbox Vector Tile encoding and decoding."
+HOMEPAGE="
+ https://github.com/tilezen/mapbox-vector-tile/
+ https://pypi.org/project/mapbox-vector-tile/
+"
+SRC_URI="https://github.com/tilezen/mapbox-vector-tile/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/pyclipper[${PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ dev-python/shapely[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( ${RDEPEND} )"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Dont install into top-level
+ sed -Ei '/include = \[/,/\]/ { /(README|CHANGELOG)/d }' pyproject.toml || die
+ default
+}
diff --git a/dev-python/mapbox-vector-tile/metadata.xml b/dev-python/mapbox-vector-tile/metadata.xml
new file mode 100644
index 000000000000..23ccc90b6e95
--- /dev/null
+++ b/dev-python/mapbox-vector-tile/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>parona@protonmail.com</email>
+ <name>Alfred Wingate</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tilezen/mapbox-vector-tile</remote-id>
+ <remote-id type="pypi">mapbox-vector-tile</remote-id>
+ </upstream>
+</pkgmetadata>