summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-06 16:16:44 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-06 16:34:22 +0100
commit780f38c78fc0306ac46488af394b414524d98b71 (patch)
tree6fb7c383a7e47ff4d3ac14b7409e71e685e69a1c /dev-python/lit
parentdev-python/clang-python: Add 15.x live ebuild (diff)
downloadgentoo-780f38c78fc0306ac46488af394b414524d98b71.tar.gz
gentoo-780f38c78fc0306ac46488af394b414524d98b71.tar.bz2
gentoo-780f38c78fc0306ac46488af394b414524d98b71.zip
dev-python/lit: Add 15.x live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/lit-15.0.0.9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/lit/lit-15.0.0.9999.ebuild b/dev-python/lit/lit-15.0.0.9999.ebuild
new file mode 100644
index 000000000000..89c5315a5acb
--- /dev/null
+++ b/dev-python/lit/lit-15.0.0.9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 llvm.org
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm
+ )"
+
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_prepare() {
+ cd "${WORKDIR}" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x LIT_PRESERVES_TMP=1
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
+}