summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-06 18:11:57 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-06 22:23:09 +0100
commitc21814c534e5c19c1724d86200004f518e7622cd (patch)
treecb9abdca2ea3b14b1044c9ac1cbe73a082742cdd /dev-python/lit/lit-11.0.1.ebuild
parentdev-python/clang-python: Bump to 11.0.1 (final) (diff)
downloadgentoo-c21814c534e5c19c1724d86200004f518e7622cd.tar.gz
gentoo-c21814c534e5c19c1724d86200004f518e7622cd.tar.bz2
gentoo-c21814c534e5c19c1724d86200004f518e7622cd.zip
dev-python/lit: Bump to 11.0.1 (final)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lit/lit-11.0.1.ebuild')
-rw-r--r--dev-python/lit/lit-11.0.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/lit/lit-11.0.1.ebuild b/dev-python/lit/lit-11.0.1.ebuild
new file mode 100644
index 000000000000..71df2cfcaad4
--- /dev/null
+++ b/dev-python/lit/lit-11.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 llvm.org
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm )"
+
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_prepare() {
+ cd "${WORKDIR}" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x LIT_PRESERVES_TMP=1
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
+}