summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-11 18:24:20 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-11 18:27:51 +0200
commit9fc4b432035ae3240808f6e4b365a264a1e251e6 (patch)
treef0bf9b69e8b2a318bb5eea19a55df367149ec75c /dev-python/kombu
parentdev-python/pytest-faulthandler: Remove old (diff)
downloadgentoo-9fc4b432035ae3240808f6e4b365a264a1e251e6.tar.gz
gentoo-9fc4b432035ae3240808f6e4b365a264a1e251e6.tar.bz2
gentoo-9fc4b432035ae3240808f6e4b365a264a1e251e6.zip
dev-python/kombu: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/kombu')
-rw-r--r--dev-python/kombu/Manifest1
-rw-r--r--dev-python/kombu/kombu-5.0.1.ebuild82
-rw-r--r--dev-python/kombu/metadata.xml7
3 files changed, 0 insertions, 90 deletions
diff --git a/dev-python/kombu/Manifest b/dev-python/kombu/Manifest
index d69a3bfeb530..a21f167444e5 100644
--- a/dev-python/kombu/Manifest
+++ b/dev-python/kombu/Manifest
@@ -1,2 +1 @@
-DIST kombu-5.0.1.tar.gz 404428 BLAKE2B 89d4c2daf70c3dcd0a990c8f045074780f2d4f13f39899c0ab3b73b473948469746cf8872aaa8565f5c4b071bf18ff510cd565e8f9b6a3735a0bf1d0af55e9b6 SHA512 aa5d35b7753f5ec8d95512c322fabf0163628b9afbd228faa2be910a1cd4ea3236a7e43485e17650e1aa9aebae59a91a2b0bdc1950e4e4c622b499a4ae29ea0e
DIST kombu-5.1.0.tar.gz 416353 BLAKE2B 2c26aac0a8eda62475e2a9a859b2548046dfce0699a8dafce3cc6471ee3b82f82882a53903a86f69cf16f948e4d0e66f379479f7f1f46aca2bcbdd031ba87811 SHA512 62ef16e8e3fb592882b8060f29b95e7224ba635132ed688eece0c2d254e7f7fb525c778cac23f15495464c6dbcf84d7a1372fde6f55fcfe66677cf43d3e9d4de
diff --git a/dev-python/kombu/kombu-5.0.1.ebuild b/dev-python/kombu/kombu-5.0.1.ebuild
deleted file mode 100644
index 189ab9bc017a..000000000000
--- a/dev-python/kombu/kombu-5.0.1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1
-
-DESCRIPTION="AMQP Messaging Framework for Python"
-HOMEPAGE="https://pypi.org/project/kombu/ https://github.com/celery/kombu"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc examples mongodb msgpack redis sqs test yaml"
-RESTRICT="!test? ( test )"
-
-# zookeeper backend support possible via dev-python/kazoo
-RDEPEND="
- >=dev-python/importlib_metadata-0.18[${PYTHON_USEDEP}]
- >=dev-python/py-amqp-2.6.0[${PYTHON_USEDEP}]
- <dev-python/py-amqp-2.7[${PYTHON_USEDEP}]
- >=dev-python/pyro-4.76:4[${PYTHON_USEDEP}]
- sqs? ( >=dev-python/boto3-1.4.4[${PYTHON_USEDEP}] )
- msgpack? ( >=dev-python/msgpack-0.3.0[${PYTHON_USEDEP}] )
- mongodb? ( >=dev-python/pymongo-3.3.0[${PYTHON_USEDEP}] )
- redis? ( >=dev-python/redis-py-3.3.11[${PYTHON_USEDEP}] )
- yaml? ( >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}] )"
-# Fix to https://github.com/celery/kombu/issues/474 obliges dev-python/pymongo to >=-3.0.2
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-20.6.7[${PYTHON_USEDEP}]
- test? (
- >=dev-python/case-1.5.2[${PYTHON_USEDEP}]
- <=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- )
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/sphinx_celery-1.1[${PYTHON_USEDEP}]
- )"
-
-# kazoo is optional for tests.
-# Refrain for now, no established demand for it from users
-
-# Req'd for test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=(
-)
-
-python_prepare_all() {
- # AttributeError: test_Etcd instance has no attribute 'patch'
- rm t/unit/transport/test_etcd.py || die
- # allow use of new (renamed) msgpack
- sed -i '/msgpack/d' requirements/extras/msgpack.txt || die
- # pytest-sugar is not packaged
- sed -i '/pytest-sugar/d' requirements/test.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # Doc build misses and skips only content re librabbitmq which is not in portage
- if use doc; then
- emake -C docs html
- fi
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/kombu/metadata.xml b/dev-python/kombu/metadata.xml
index 75f472f07e2c..659be9f1d87e 100644
--- a/dev-python/kombu/metadata.xml
+++ b/dev-python/kombu/metadata.xml
@@ -10,11 +10,4 @@
<remote-id type="pypi">kombu</remote-id>
<remote-id type="github">celery/kombu</remote-id>
</upstream>
- <use>
- <flag name="sqs">Enables Amazon SQS transport module for Kombu</flag>
- <flag name="mongodb">Enables MongoDB backend</flag>
- <flag name="msgpack">Enables MessagePack (de)serializer for Python</flag>
- <flag name="redis">Enables Redis backend</flag>
- <flag name="yaml">Enables yaml backend</flag>
- </use>
</pkgmetadata>