summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-13 14:07:10 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-13 14:12:31 +0100
commitad1ee49fc7c4522d5499acbb4d2a34295ad850e5 (patch)
tree5cac865cbbb61f70f04edeb7c205e5eb7015da36 /dev-python/jupyter_ydoc/jupyter_ydoc-0.2.2.ebuild
parentdev-python/jupyter_server_ydoc: add 0.6.1 (diff)
downloadgentoo-ad1ee49fc7c4522d5499acbb4d2a34295ad850e5.tar.gz
gentoo-ad1ee49fc7c4522d5499acbb4d2a34295ad850e5.tar.bz2
gentoo-ad1ee49fc7c4522d5499acbb4d2a34295ad850e5.zip
dev-python/jupyter_ydoc: add 0.2.2
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_ydoc/jupyter_ydoc-0.2.2.ebuild')
-rw-r--r--dev-python/jupyter_ydoc/jupyter_ydoc-0.2.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/jupyter_ydoc/jupyter_ydoc-0.2.2.ebuild b/dev-python/jupyter_ydoc/jupyter_ydoc-0.2.2.ebuild
new file mode 100644
index 000000000000..42240178e1de
--- /dev/null
+++ b/dev-python/jupyter_ydoc/jupyter_ydoc-0.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Document structures for collaborative editing using Ypy"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/jupyter_ydoc/
+ https://pypi.org/project/jupyter-ydoc/
+"
+SRC_URI="https://github.com/jupyter-server/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Requires node
+RESTRICT="test"
+
+RDEPEND="
+ <dev-python/y-py-0.6.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ dev-python/ypy-websocket[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# Hangs for some reason
+#distutils_enable_sphinx docs/source dev-python/myst_parser dev-python/pydata-sphinx-theme