summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-07 05:54:02 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-07 06:42:59 +0200
commit35a83e031b2e8f79729b2a2730cf4c879308ecb3 (patch)
tree46f605ee9bd563f41a157a37ea42b20be3e9da0d /dev-python/jq
parentdev-python/asttokens: Remove old (diff)
downloadgentoo-35a83e031b2e8f79729b2a2730cf4c879308ecb3.tar.gz
gentoo-35a83e031b2e8f79729b2a2730cf4c879308ecb3.tar.bz2
gentoo-35a83e031b2e8f79729b2a2730cf4c879308ecb3.zip
dev-python/jq: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jq')
-rw-r--r--dev-python/jq/Manifest2
-rw-r--r--dev-python/jq/files/jq-1.5.0-cython3.patch20
-rw-r--r--dev-python/jq/jq-1.4.1.ebuild39
-rw-r--r--dev-python/jq/jq-1.5.0-r1.ebuild44
-rw-r--r--dev-python/jq/jq-1.5.0.ebuild39
5 files changed, 0 insertions, 144 deletions
diff --git a/dev-python/jq/Manifest b/dev-python/jq/Manifest
index beaf41c2f223..a4a6ab185189 100644
--- a/dev-python/jq/Manifest
+++ b/dev-python/jq/Manifest
@@ -1,3 +1 @@
-DIST jq.py-1.4.1.gh.tar.gz 2648592 BLAKE2B b1413a07ba03f61d3b2e8cfa3f2c646408e24139f76fb9637d23968d953fa78f82b1dd04c355d5a6e6c6761095a4814d8cfd1f012382ca810ad5a44e007c7878 SHA512 03924793e8cab8041b4b2ecb8ef45bafdf31f14b4502170358ddecc027ead7cc17eda37fc04743eeef073e29144d2f7e6c4428e2a92f1bb8aa859100dce4521b
-DIST jq.py-1.5.0.gh.tar.gz 2649404 BLAKE2B 9dfe8f17e061eaea44de31be17cbb18607dc118d526a652a80e2d69b30fa532f412b9b20b1c72418f4d6904b43126611344b2257bc9cb3441086ef3e8f131a6e SHA512 826771ced7d707111b7bc6d1f7a408944690daa8bfb6ec135627a15c3fcfba95a525b8ee3005f8a6e5d23afbeaacc06ad7464e3c3a0a15cf5582d97121c64248
DIST jq.py-1.6.0.gh.tar.gz 2842673 BLAKE2B 5ef2d2c6641483123b030c508b04e8f1574a5ca3168a2bacfd7c5a4ad01344d677f723cc3317677275496bd56412c5ab64370ed87b70dcb91dd1d8328daf65a8 SHA512 91e2c0890cece4f09e362c0ae691c768be64ba0d8e0d7441c9a459be37ff70ee816d179c21759ee053b2b434fc0a6998d90b660ae1f1456d4f506474cb80d88e
diff --git a/dev-python/jq/files/jq-1.5.0-cython3.patch b/dev-python/jq/files/jq-1.5.0-cython3.patch
deleted file mode 100644
index b4b66b65139c..000000000000
--- a/dev-python/jq/files/jq-1.5.0-cython3.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-https://bugs.gentoo.org/898684
-https://github.com/mwilliamson/jq.py/commit/c2c7ed1f25b51947ebb690f6b8464c78fe83bb2b
-
-From c2c7ed1f25b51947ebb690f6b8464c78fe83bb2b Mon Sep 17 00:00:00 2001
-From: Michael Williamson <mike@zwobble.org>
-Date: Thu, 31 Aug 2023 23:11:28 +0100
-Subject: [PATCH] Add explicit noexcept to _store_error for Cython 3
- compatibility
-
---- a/jq.pyx
-+++ b/jq.pyx
-@@ -172,7 +172,7 @@ cdef jq_state* _compile(object program_bytes, object args) except NULL:
- return jq
-
-
--cdef void _store_error(void* store_ptr, jv error):
-+cdef void _store_error(void* store_ptr, jv error) noexcept:
- # TODO: handle errors not of JV_KIND_STRING
- cdef _ErrorStore store = <_ErrorStore>store_ptr
- if jv_get_kind(error) == JV_KIND_STRING:
diff --git a/dev-python/jq/jq-1.4.1.ebuild b/dev-python/jq/jq-1.4.1.ebuild
deleted file mode 100644
index 093658b0c385..000000000000
--- a/dev-python/jq/jq-1.4.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P="jq.py-${PV}"
-DESCRIPTION="Python bindings for jq"
-HOMEPAGE="
- https://github.com/mwilliamson/jq.py/
- https://pypi.org/project/jq/
-"
-SRC_URI="
- https://github.com/mwilliamson/jq.py/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-# cython<3: https://bugs.gentoo.org/898684
-BDEPEND="
- <dev-python/cython-3[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_compile() {
- # Cython compilation isn't part of setup.py, so do it manually
- "${EPYTHON}" -m cython -3 jq.pyx -o jq.c || die
- distutils-r1_python_compile
-}
diff --git a/dev-python/jq/jq-1.5.0-r1.ebuild b/dev-python/jq/jq-1.5.0-r1.ebuild
deleted file mode 100644
index cabe52d95c3b..000000000000
--- a/dev-python/jq/jq-1.5.0-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P="jq.py-${PV}"
-DESCRIPTION="Python bindings for jq"
-HOMEPAGE="
- https://github.com/mwilliamson/jq.py/
- https://pypi.org/project/jq/
-"
-SRC_URI="
- https://github.com/mwilliamson/jq.py/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-cython3.patch
-)
-
-distutils_enable_tests pytest
-
-python_compile() {
- # TODO: export JQPY_USE_SYSTEM_LIBS=1 on next release
-
- # Cython compilation isn't part of setup.py, so do it manually
- "${EPYTHON}" -m cython -3 jq.pyx -o jq.c || die
- distutils-r1_python_compile
-}
diff --git a/dev-python/jq/jq-1.5.0.ebuild b/dev-python/jq/jq-1.5.0.ebuild
deleted file mode 100644
index bbe209456231..000000000000
--- a/dev-python/jq/jq-1.5.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P="jq.py-${PV}"
-DESCRIPTION="Python bindings for jq"
-HOMEPAGE="
- https://github.com/mwilliamson/jq.py/
- https://pypi.org/project/jq/
-"
-SRC_URI="
- https://github.com/mwilliamson/jq.py/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# cython<3: https://bugs.gentoo.org/898684
-BDEPEND="
- <dev-python/cython-3[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_compile() {
- # Cython compilation isn't part of setup.py, so do it manually
- "${EPYTHON}" -m cython -3 jq.pyx -o jq.c || die
- distutils-r1_python_compile
-}