summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-04 06:52:54 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-04 06:52:54 +0100
commitcc40baa6b844e75ddf49505a8aeaa5014bdb491b (patch)
tree7f92d8d8abdde223a26719d8019a99bd3eb740d5 /dev-python/jeepney/jeepney-0.8.0.ebuild
parentsys-kernel/gentoo-kernel-bin: Bump to 6.0.7 (diff)
downloadgentoo-cc40baa6b844e75ddf49505a8aeaa5014bdb491b.tar.gz
gentoo-cc40baa6b844e75ddf49505a8aeaa5014bdb491b.tar.bz2
gentoo-cc40baa6b844e75ddf49505a8aeaa5014bdb491b.zip
dev-python/jeepney: Remove trio deps from test-dep
Make trio tests entirely optional, as dev-python/trio now requires Rust indirectly. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jeepney/jeepney-0.8.0.ebuild')
-rw-r--r--dev-python/jeepney/jeepney-0.8.0.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-python/jeepney/jeepney-0.8.0.ebuild b/dev-python/jeepney/jeepney-0.8.0.ebuild
index 93b70d360eac..4edbf80ec1e2 100644
--- a/dev-python/jeepney/jeepney-0.8.0.ebuild
+++ b/dev-python/jeepney/jeepney-0.8.0.ebuild
@@ -9,7 +9,10 @@ PYTHON_COMPAT=( pypy3 python3_{8..11} )
inherit distutils-r1
DESCRIPTION="Low-level, pure Python DBus protocol wrapper"
-HOMEPAGE="https://gitlab.com/takluyver/jeepney/"
+HOMEPAGE="
+ https://gitlab.com/takluyver/jeepney/
+ https://pypi.org/project/jeepney/
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
@@ -23,10 +26,6 @@ BDEPEND="
>=dev-python/pytest-asyncio-0.7.1[${PYTHON_USEDEP}]
dev-python/testpath[${PYTHON_USEDEP}]
sys-apps/dbus
- $(python_gen_cond_dep '
- dev-python/pytest-trio[${PYTHON_USEDEP}]
- dev-python/trio[${PYTHON_USEDEP}]
- ' 'python3*')
)
"
@@ -48,8 +47,7 @@ src_test() {
python_test() {
local EPYTEST_IGNORE=()
- # keep in sync with python_gen_cond_dep!
- if [[ ${EPYTHON} != python3* ]]; then
+ if ! has_version "dev-python/pytest-trio[${PYTHON_USEDEP}]"; then
EPYTEST_IGNORE+=( jeepney/io/tests/test_trio.py )
fi
epytest