summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-25 13:33:52 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-25 14:08:45 +0200
commit37ecef57b094d357d864b46d04a798e1656f1063 (patch)
treeab0563d917bb41194ee2183b7f2b6428bf491ccc /dev-python/jedi
parentdev-python/parso: Remove old (diff)
downloadgentoo-37ecef57b094d357d864b46d04a798e1656f1063.tar.gz
gentoo-37ecef57b094d357d864b46d04a798e1656f1063.tar.bz2
gentoo-37ecef57b094d357d864b46d04a798e1656f1063.zip
dev-python/jedi: Bump to 0.18.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jedi')
-rw-r--r--dev-python/jedi/Manifest3
-rw-r--r--dev-python/jedi/jedi-0.18.1.ebuild79
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/jedi/Manifest b/dev-python/jedi/Manifest
index 8528671239e1..f57f4c13c346 100644
--- a/dev-python/jedi/Manifest
+++ b/dev-python/jedi/Manifest
@@ -1,3 +1,6 @@
DIST django-stubs-1.5.0.tar.gz 180400 BLAKE2B 0619a76f89fe4fad456a82e3048009f25fdfd8b8e3071fd5a0cc0eebd62b3e9e8b77d29c5e4e8d1e0297fc466cc7e0c49771750b609fff49516e2aa1499c198b SHA512 c3e89f02a22561b5446e1cc0f01be791767984b5791fe5bd362ec6128e2ba7b32e921f9ee719a80ace05f7f0c84a912731700b457761f64617c1415cd232c7da
+DIST django-stubs-fd057010f6cbf176f57d1099e82be46d39b99cb9.tar.gz 183312 BLAKE2B a68f6139903f5001db994ee0d881f40ab74932e81c3e2c3a0c22dc56e6be681d0fb42ce837603b21e4d0d448ccb25884ef0f69039305f309e82603267cee9f6a SHA512 506322c132f94e6a1e88cdbde6027a566387731fa6ad59934f95c3511f49d90eff2a3138363811be648b096407d418cd1f801df0bc35b1e464ef181e4076ada1
DIST jedi-0.18.0.tar.gz 462786 BLAKE2B 35021ed1566fffc24056060f16b8a0aa6f8b6e382f716ff5978711fd66340e96f4e0b628463aadead5605db32cfc20df06a6c53a9b435658f1c455a6212da6e5 SHA512 fcee84496285a0b0b1cf1f3827593d0603bd87c84baf725cc7bdbf594979f49729b18a29b7465848413bdd3a5670fcc41187dd3eadbd9750d77788c5a9408dbf
+DIST jedi-0.18.1.tar.gz 466884 BLAKE2B c2403b20447b27b1fb19c16d1131299154fcb767453116964b339bf7ef4a1ca20b6c3216c3fbd63c304dd2c0c02a67702d5228e1d847975b778597dc58b489d1 SHA512 c72dc4927fe44641ea57c61e68b3c74c3a3f70ddc2990454ba931026c288723e07263918ecbb4ecc6f79716d37e10a1b1448ae8cfc6d52465122b3d1e43bea25
+DIST typeshed-ae9d4f4b21bb5e1239816c301da7b1ea904b44c3.tar.gz 602044 BLAKE2B 53298918a7e9a1163e76d4c70ad2a2117ee90b49329aa82d82b2aaaeaf000c971872f83ed283af6dc4be068b813876760c8b1b4acb4131865572a4aed3ea9230 SHA512 b3b9da66b6c6e03e0b262b3262df31215a5e080468ca9ebf4332ed53d715cd3956db7067fad3ec267042ff704f81ac665c703ef2fd0c5b445d440bd8e52bf1aa
DIST typeshed-jedi_v0.16.0.tar.gz 497407 BLAKE2B d322d70d3c46d1abcedddbd10aed5c6f213698f4e9f9aec1b4bd7e7186ab7ce384ec6a95d6adc46c7459e3bbb748d6ff432115cae744a315aed60972d2390eee SHA512 1551082938b52717f90e28ffd25e838ab04798ea86ea719fa35975a9de006bcc063a00cc8c8babd994990cdff694d48490f4d8c898c322666450d7ef3be8688a
diff --git a/dev-python/jedi/jedi-0.18.1.ebuild b/dev-python/jedi/jedi-0.18.1.ebuild
new file mode 100644
index 000000000000..695103134ebb
--- /dev/null
+++ b/dev-python/jedi/jedi-0.18.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+TYPESHED_P="typeshed-ae9d4f4b21bb5e1239816c301da7b1ea904b44c3"
+DJANGO_STUBS_P="django-stubs-fd057010f6cbf176f57d1099e82be46d39b99cb9"
+
+DESCRIPTION="Autocompletion library for Python"
+HOMEPAGE="
+ https://github.com/davidhalter/jedi/
+ https://pypi.org/project/jedi/
+"
+SRC_URI="
+ https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://github.com/davidhalter/typeshed/archive/${TYPESHED_P#typeshed-}.tar.gz
+ -> ${TYPESHED_P}.tar.gz
+ https://github.com/davidhalter/django-stubs/archive/${DJANGO_STUBS_P#django-stubs-}.tar.gz
+ -> ${DJANGO_STUBS_P/v/}.tar.gz
+"
+
+LICENSE="
+ MIT
+ test? ( Apache-2.0 )
+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ =dev-python/parso-0.8*[${PYTHON_USEDEP}]
+"
+
+# RDEPEND needed because of an import jedi inside conf.py
+distutils_enable_sphinx docs \
+ dev-python/parso \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # upstream includes these as submodules ...
+ rmdir "${S}"/jedi/third_party/{django-stubs,typeshed} || die
+ mv "${WORKDIR}/${DJANGO_STUBS_P/v/}" \
+ "${S}/jedi/third_party/django-stubs" || die
+ mv "${WORKDIR}/${TYPESHED_P}" \
+ "${S}/jedi/third_party/typeshed" || die
+
+ # don't run doctests, don't depend on colorama
+ sed -i "s:'docopt',:: ; s:'colorama',::" setup.py || die
+ sed -i "s: --doctest-modules::" pytest.ini || die
+
+ # test_complete_expanduser relies on $HOME not being empty
+ > "${HOME}"/somefile || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fragile
+ test/test_speed.py
+ # assumes pristine virtualenv
+ test/test_inference/test_imports.py::test_os_issues
+ )
+ [[ ${EPYTHON} != python3.8 ]] && EPYTEST_DESELECT+=(
+ # TODO
+ 'test/test_integration.py::test_completion[lambdas:112]'
+ )
+
+ # some plugin breaks case-insensitivity on completions
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # django and pytest tests are very version dependent
+ epytest -k "not django and not pytest"
+}