summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-19 05:00:25 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-19 05:10:35 +0100
commitdd7155b91f32a9d33180d17bf290ff9cdae4c69f (patch)
treeb8f2d1ff690ba92f401e18f8c190875bc3d50e77 /dev-python/identify
parentdev-python/pyupgrade: Bump to 3.15.1 (diff)
downloadgentoo-dd7155b91f32a9d33180d17bf290ff9cdae4c69f.tar.gz
gentoo-dd7155b91f32a9d33180d17bf290ff9cdae4c69f.tar.bz2
gentoo-dd7155b91f32a9d33180d17bf290ff9cdae4c69f.zip
dev-python/identify: Bump to 2.5.35
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/identify')
-rw-r--r--dev-python/identify/Manifest1
-rw-r--r--dev-python/identify/identify-2.5.35.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index 3e5a9795b60d..c2dd428126c1 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1,2 +1,3 @@
DIST identify-2.5.33.gh.tar.gz 101683 BLAKE2B 0b66bc611e5ba01029c2d8aa13146025eb68296793a148eafecc7584d3d68d77d8ebae67306e8fc64e7265ab673fa4852497f25b9ba73e895c61e4f4ec2997e2 SHA512 cb3cc2064814b6694122040dc1be31f09bbddaf988f15425717d5561f175b216e62f4449cff5d697a8d612a48513e97446973bba42f376cdcfad1d93d1e14cf7
DIST identify-2.5.34.gh.tar.gz 101695 BLAKE2B 94522c083ce2584831bd61b6d7e34533f08ad3814ccde93b7340139bcc4dc05fa6384024e6f15cc33e480de06117d17a88d148044758658e7cb302bfab7d7366 SHA512 bf9fe2bdca46b1e9a7f1e4559178061bb5293d43b42962d17a08b6f9230c3d2d004b74ac3b1c825905fa77631533565b26c95a0fa99f2bb9a3320d2d4a5f67aa
+DIST identify-2.5.35.gh.tar.gz 101691 BLAKE2B 931169744a9126d82b32bd4dea1731f1f4ad209b78d3df9ce490891994194797a7adcaff19400e9856716528f5b3490e05c8e06614c788b089251ef92cd1dd03 SHA512 1d01535f95818533220c06988eb2d9f495c004b41fd197482ab0e3520f81ab2aebce0344dffeb0449423abd6574c21043fa0ad20472b3aaff6cb97986f31fd88
diff --git a/dev-python/identify/identify-2.5.35.ebuild b/dev-python/identify/identify-2.5.35.ebuild
new file mode 100644
index 000000000000..0aa9daac20bc
--- /dev/null
+++ b/dev-python/identify/identify-2.5.35.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest