summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-02-04 19:14:09 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-02-04 19:14:09 +0200
commit3f679ed04036bedb6598fa9fdc2815e9b588bf63 (patch)
treedddc0b8973391a1327b8d767694048ec793543be /dev-python/httpcore
parentdev-python/uvicorn: add 0.17.4 (diff)
downloadgentoo-3f679ed04036bedb6598fa9fdc2815e9b588bf63.tar.gz
gentoo-3f679ed04036bedb6598fa9fdc2815e9b588bf63.tar.bz2
gentoo-3f679ed04036bedb6598fa9fdc2815e9b588bf63.zip
dev-python/httpcore: add 0.14.7
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest1
-rw-r--r--dev-python/httpcore/httpcore-0.14.7.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index dce3f0900208..53d6932bdbf9 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -3,3 +3,4 @@ DIST httpcore-0.14.3.tar.gz 64650 BLAKE2B 140c55af60f54ff13db958cecef50af2b88578
DIST httpcore-0.14.4.tar.gz 68463 BLAKE2B cc6c17da3b97c2a8fb9edb0aeb6247904240748645f605b2f3c84194fc06bab10f568ce21b8beaf1dee9a8d68166f1691e00f17e44d89efce0a18a6fbd91d5a5 SHA512 4dfb2d0dd10df1de45f4e78ddedddf02bf500a81a0132919894bd5c07f02a2975ce589ba3f6d79dd92ec882128f86f338bd32f35cdecb6618307e446ed369310
DIST httpcore-0.14.5.tar.gz 74227 BLAKE2B 8e54b6b40d35a9228b96682d87651a6d3967441b74f3544a21b378620b417b48978f51d25b1980d87fad4748537036c6f2a4751e8b58e622c7c76389ff1afb67 SHA512 1705cf83df3ead454065e2ed4c300697c5d0a6609846a3eadfca2af2d9c1578f951c2f4bf3ac018c3cc984d2d2ccd39c4b2de781747588a6116eebe1007afff0
DIST httpcore-0.14.6.tar.gz 75303 BLAKE2B 408d140e754cf765809af2549d0ae8a076c63ef9df8358596fd893e2a744c95353fa1f8cadaafc5ca9b4710a87db6c27bdae1f5913f83a7d69c7b9b45192e994 SHA512 a3e2474619fec999150c5e2adb475e000b1d2de4ec84a9e93788e816717cd699f0ddc3494ec9e6f07cb1c6a95d74d39a83799ac4fd07d02a8fab72a1253b97ba
+DIST httpcore-0.14.7.gh.tar.gz 75844 BLAKE2B 50d5fac7f44996cc5a08b4f994c2109b173e5b9fea080c8740309b799421d012a70280a84fffe93e290bf425e5ee6eb1bfcb74aff81fa7e737c21f25019e6664 SHA512 6865e97f9b84846bb4e9304ea358b0a28d66fd2d1e244e8a2a439ee446a294ecbc68ac07d5a718fd1c3eceaa44a391d7a8f7f2ca659f1674eb17a90f39987d48
diff --git a/dev-python/httpcore/httpcore-0.14.7.ebuild b/dev-python/httpcore/httpcore-0.14.7.ebuild
new file mode 100644
index 000000000000..9dde29c8419e
--- /dev/null
+++ b/dev-python/httpcore/httpcore-0.14.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="https://www.encode.io/httpcore/"
+SRC_URI="
+ https://github.com/encode/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ =dev-python/anyio-3*[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/h11-0.13[${PYTHON_USEDEP}]
+ <dev-python/h2-5[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "SOCKS support" dev-python/socksio
+}