summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-23 07:01:10 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-23 08:03:45 +0200
commite843fe9713542edea8c57fb342cfcd9c295da2ed (patch)
tree18c3dc2eb462d2e95db5f739430c1d06081a373f /dev-python/html5lib/html5lib-1.1.ebuild
parentdev-python/boto3: Bump to 1.14.8 (diff)
downloadgentoo-e843fe9713542edea8c57fb342cfcd9c295da2ed.tar.gz
gentoo-e843fe9713542edea8c57fb342cfcd9c295da2ed.tar.bz2
gentoo-e843fe9713542edea8c57fb342cfcd9c295da2ed.zip
dev-python/html5lib: Bump to 1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/html5lib/html5lib-1.1.ebuild')
-rw-r--r--dev-python/html5lib/html5lib-1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/html5lib/html5lib-1.1.ebuild b/dev-python/html5lib/html5lib-1.1.ebuild
new file mode 100644
index 000000000000..16f72f8d42f7
--- /dev/null
+++ b/dev-python/html5lib/html5lib-1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/ https://html5lib.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT+=" !test? ( test )"
+
+RDEPEND=">=dev-python/six-1.9[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest-expect[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest