summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-21 21:12:11 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-21 22:25:06 +0100
commita94217f99b233486eb5af6858ce9f94bc8fe1737 (patch)
tree0a98d2ee5e5ac8f0b34ceb16b3c1cc896bb3eb53 /dev-python/hpack
parentdev-python/hyperframe: Bump to 5.2.0, EAPI 7, py3.8 (diff)
downloadgentoo-a94217f99b233486eb5af6858ce9f94bc8fe1737.tar.gz
gentoo-a94217f99b233486eb5af6858ce9f94bc8fe1737.tar.bz2
gentoo-a94217f99b233486eb5af6858ce9f94bc8fe1737.zip
dev-python/hpack: Enable py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hpack')
-rw-r--r--dev-python/hpack/hpack-3.0.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/hpack/hpack-3.0.0.ebuild b/dev-python/hpack/hpack-3.0.0.ebuild
index 93a872a12ec6..65570c88f59d 100644
--- a/dev-python/hpack/hpack-3.0.0.ebuild
+++ b/dev-python/hpack/hpack-3.0.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy)
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy)
inherit distutils-r1
@@ -14,6 +14,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=""
# dev-python/pytest-relaxed causes tests to fail
@@ -33,5 +34,5 @@ python_prepare_all() {
}
python_test() {
- py.test -vv hpack test || die "Tests fail with ${EPYTHON}"
+ pytest -vv hpack test || die "Tests fail with ${EPYTHON}"
}