summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-24 06:46:17 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-24 06:46:17 +0100
commit22b02af534c4962be38d7d22f4333a35a6e52126 (patch)
treec99ea30a4750867ba182d9167df9eb1b96d96305 /dev-python/google-auth
parentdev-python/google-api-python-client: Remove old (diff)
downloadgentoo-22b02af534c4962be38d7d22f4333a35a6e52126.tar.gz
gentoo-22b02af534c4962be38d7d22f4333a35a6e52126.tar.bz2
gentoo-22b02af534c4962be38d7d22f4333a35a6e52126.zip
dev-python/google-auth: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.24.0.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 56f816f8c941..ed407c6e40bc 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,2 +1 @@
-DIST google-auth-2.24.0.tar.gz 234771 BLAKE2B 05111637ae26529b9345ef1f3ce8334bbcfc782e93d560749205a18e50075593573130e6ba3d33e79cd0190305ae382d44aac071c12ab67df7a8064a041220f2 SHA512 e4987b8e52be45e2fd2906525e1a4645f73b2322a6d7055f9b9c00555f4ffe05b7cda6e21cbf9f491e1e0f2b43772050017b7473b24a92cf5ca6ae6e589a15e0
DIST google-auth-2.25.2.tar.gz 235648 BLAKE2B 527dada4cff9139ef2b90874aafe085e7b92f4edecfa3dfb6cf26a40e8470f68451fdc88bf5a9ce92144b7448ee4a32a011069b62d6ee02d0885db1ceb319f22 SHA512 2f03dbe6664cfd7086da82154a8fbea6cb97f3f05992faa0fc11399248d645eafa0b63e4f45e248ff73de693c15050f3dfa7060b0f46c8b22919619d5ebb82e2
diff --git a/dev-python/google-auth/google-auth-2.24.0.ebuild b/dev-python/google-auth/google-auth-2.24.0.ebuild
deleted file mode 100644
index 4dac18775bcd..000000000000
--- a/dev-python/google-auth/google-auth-2.24.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Google Authentication Library"
-HOMEPAGE="
- https://github.com/googleapis/google-auth-library-python/
- https://pypi.org/project/google-auth/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
-
-RDEPEND="
- <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pyu2f[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # these are compatibility tests with oauth2client
- # disable them to unblock removal of that package
- tests/test__oauth2client.py
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}