summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-23 04:18:07 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-23 04:37:05 +0100
commita2ed2445cc1aff076a59e1b548cd580b0775d59b (patch)
tree8977cb28d2442f9c689fca80384ea3ccb973847b /dev-python/google-api-python-client
parentdev-python/oslo-log: Bump to 5.5.0 (diff)
downloadgentoo-a2ed2445cc1aff076a59e1b548cd580b0775d59b.tar.gz
gentoo-a2ed2445cc1aff076a59e1b548cd580b0775d59b.tar.bz2
gentoo-a2ed2445cc1aff076a59e1b548cd580b0775d59b.zip
dev-python/google-api-python-client: Bump to 2.119.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.119.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index bd5a7d3043a2..c82155668970 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,3 +1,4 @@
DIST google-api-python-client-2.116.0.tar.gz 11545357 BLAKE2B 26b3949ee377a064db4e9108feb1fbca429bf71e97e4d7d07ac00422952faa7aa4682a77641470a199b81f69172514b04015ea6f55f4761aa087d9eeab58922b SHA512 757d74b45abc570756965f7cd8bab0c833be151c59f64aa103a69d97d581b6b29c5c6c6ad1536067a99be1ef3d77cfdbdbaf309a5068b01b2d6a76d4733eedb7
DIST google-api-python-client-2.117.0.tar.gz 11565859 BLAKE2B f1b8c82b48759de7070ded748f968ce16581a6aabd4b71691e210b06094e0bf461dbc22c9b15cfdd588d98253d4b2cf19f66a21fc37c518af7326dca66925124 SHA512 7e1935fcdaa26f904dcddb2e2df2b1a0d7e1ea04957368b1dd30dd9d63e75fd084f30b6326c22e3b9b554c713f44a458f5a6e65b3c0b72e6b8c64fb2aef4c0ea
DIST google-api-python-client-2.118.0.tar.gz 11597120 BLAKE2B 4736ad9c8d23ef0706a873e8dc17f50a229294fe202b3c46109c39a157cb2978fb23436aeee5159bd26f0da7b0edcfc321890e8a2a9fa141fcb93647fb9a5753 SHA512 56703f7f1a54a5180c76492f1281da28acc261263e48d4ac3f85c75007f6aa5f6fddffaf79eb421bfd8e4ac47332322dcba21db9c77dcfffbb8c099d45c010db
+DIST google-api-python-client-2.119.0.tar.gz 11704086 BLAKE2B ff7d2eb62559a042a272a4493ac9eb4e25f0a91dd085c172a6356e952e346d2d79d1818b57bc258725065bd19e72d9e787b021e17672361e8ff02b08b1be65cb SHA512 2acd84b059f3500e45398d2de4d6cab0941c40d7c501414c358992d6f0b305349213a2f96372a4d8b091202c87692e337036c213425b0813cc9203c5d323d966
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.119.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.119.0.ebuild
new file mode 100644
index 000000000000..c5a2303ef5ac
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.119.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}