summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-21 19:47:00 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-21 19:47:00 +0100
commit604399805046f6dc6c6aa004f28811f1073eacb2 (patch)
tree1f4976dea8f998d9c722bd578793faa84d2e19d4 /dev-python/google-api-python-client
parentdev-python/watchdog: Remove old (diff)
downloadgentoo-604399805046f6dc6c6aa004f28811f1073eacb2.tar.gz
gentoo-604399805046f6dc6c6aa004f28811f1073eacb2.tar.bz2
gentoo-604399805046f6dc6c6aa004f28811f1073eacb2.zip
dev-python/google-api-python-client: Bump to 2.79.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.79.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 1505790e943f..c406c8ad3baa 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -2,3 +2,4 @@ DIST google-api-python-client-2.74.0.gh.tar.gz 38189426 BLAKE2B 927345937faf5742
DIST google-api-python-client-2.76.0.gh.tar.gz 38245213 BLAKE2B 28d7ea8fb169b08cfc689b2957de84e1f860fb2857f4cf85e40bcdbe8c728e6179194d5dfe65103d1ed17a604d880011b2a82b4e555dc6ed6e9e73737fc5e8bc SHA512 01f1245b8a64cf5adae42b941b88eb05db4a21db4e16b35f98a077c223e795538b654f348f4b0a7bfde8e8928c3c57cd841dca41755a57ee0a6965b89f58cdf9
DIST google-api-python-client-2.77.0.gh.tar.gz 38300787 BLAKE2B c7d147b9ae78fff5aa70b2ba219888296d414c1f7b498c93bb424d06c437a50d5a1a2284062e58defb29ba3aa89b225e4218d9acd303a0e17f3ec4ab0380a2f6 SHA512 24aa2b3d709de83b76be2d8030a419d0e3f8f447852d7f95c6cf735134270a7af94edd86bcc3d82cd25af2497f30ac6c365ac88494c227b19faecb8e3706c261
DIST google-api-python-client-2.78.0.gh.tar.gz 38327369 BLAKE2B 291941a44a6fc9da7df2cbb108ba90babac33916f9c36aeae6e8b1575e9851f7c93aaea09340d36acd8f80dbe5ebe63820d60edc0aec14ee4859a47dcf66e344 SHA512 fff05aa981106aaccb689aeeace62734df77fefe7132481a11bc81b249a7793c1743c7c7c21116b3f5d4d59230ec7adac090d478969f8847bc201a2a23dd072d
+DIST google-api-python-client-2.79.0.gh.tar.gz 38537790 BLAKE2B 968a33a92bff0b7bc6e01e69df3b405b189df1560e1100de6bfb987ba5d87f1da9dafa184966f55f1d64b41912790f94a98d5160dd042661a2d5acc02c6d10e3 SHA512 c16e32306eb8660facbaa078fc76ad49692948f26d81d753977d1cfa49f76b4eacf2a5613c4bdb8f463ebd65c955d5edda415355d143ce1dd59ec7443eeb0a13
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.79.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.79.0.ebuild
new file mode 100644
index 000000000000..65893f1d07cd
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.79.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+SRC_URI="
+ https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}