summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-07 05:08:35 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-07 05:15:38 +0200
commit4f61212b6096aa6a5d67bcbf25f41597baf9e208 (patch)
tree2f428ee3c664d2e20bf599e35247655f792c392d /dev-python/google-api-python-client
parentdev-python/pyaml: Bump to 23.9.3 (diff)
downloadgentoo-4f61212b6096aa6a5d67bcbf25f41597baf9e208.tar.gz
gentoo-4f61212b6096aa6a5d67bcbf25f41597baf9e208.tar.bz2
gentoo-4f61212b6096aa6a5d67bcbf25f41597baf9e208.zip
dev-python/google-api-python-client: Bump to 2.98.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.98.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index c82c8497866a..155550a2d8c2 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,3 +1,4 @@
DIST google-api-python-client-2.95.0.tar.gz 11044697 BLAKE2B 1a28798146d2f321f0455dd092430cefb6d15ddc3469ba0b5ee2aab6546c4c56477379e970ac4b0eeb1a969d53a5ea002206145c046bbfa89c1b6d65dad5a2d1 SHA512 3e8419d4de8e1604365b47bc13ebb69939f2c86bc46e1e08277a3766a23f03660c25ab9113a13b6abbfee2afb4f49678144bb11c4a423c4cf05c83717863183e
DIST google-api-python-client-2.96.0.tar.gz 11464696 BLAKE2B 5cec3b123ffe03f812909dd2f1aeb723ceacd657a5e3e796f358fde5c79fa274fb45a01a2857c9fbcb5431f00384792b1c3f721fafbf2c58e6732bb352539dc7 SHA512 94b59d38df431b1624192946f84229f100870c44eaa304f740dc1ff8973bf54f9c1bf59315aa826f122ec4b46c21507d4f2c5f691a18804e57d81379848346e8
DIST google-api-python-client-2.97.0.tar.gz 11493962 BLAKE2B 243ee33b169f13e311839a3c57a4922a7ef8c09be9ffb02520580bd11b894ffa1116479abd0942503627d958f4553bc1e921a20c9ab05a4cd1386f585ca286c5 SHA512 bdbe64c3186347f111138963e70411f13ba3a8fd342cac5e93d8415093404c8ade9f53b3d81c8fb6e876095eb0016dc4efc1de9e61df1e308d6d359a3578db96
+DIST google-api-python-client-2.98.0.tar.gz 11651975 BLAKE2B 11dbe1ef86243d948887490421926c951339714b79ae62746b2c0b016505cae6e62dad8102f93ea48031dd686f21ad353210e5ac9843ab39fe9bb1d87eac4580 SHA512 dbf2b2bf6ae8934f7d2c20369eecc0ee00d21d96615e064bacdf4999ebda4a58897b0cab463958bfa39404fe7c1b922168710ef30d5f37849a076c409e2d12e0
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.98.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.98.0.ebuild
new file mode 100644
index 000000000000..0194f9640998
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.98.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}